Logi Nu
Posts: 1
Registered: ‎12-01-2013


     My USB adapter that I use with my G330 headset has stopped working. One second it worked and the next, it was not recognized. I have tried all of the USB ports and they did not work. I unpluged the adapter and found that the headset worked, but now that I want to use the microphone, I need help making my computer recognize it.

Retired Logitech Employee / Moderator (Inactive)
Posts: 1,398
Registered: ‎10-21-2013

Re: G330

Hi Dwarf-Fett,


We can try to update the drivers in your PC for your Logitech Gaming Headset G330. Please follow the steps below to try to fixz this issue.


  1. Open the Device Manager and expand the Sound section.
  2. Right click on the Logitech Gaming Headset G330 and select Uninstall.
  3. Unplug the headset and restart the computer.
  4. After the computer boots up, plug the headset into a different USB port.
  5. Wait for the drivers to load, once they're installed you should get a message saying: Your device is ready to use.

However, if updating the drivers don't solve your issue, there's a chance that the issue is related to the hardware of your USB adapter. To identify if this is the case, try to use your headset with a different PC.


Best Regards,

Support Specialist

Support + Download | Contact Support | Manuals | Check Rebate Status
If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.