Logi Nu
Posts: 1
Registered: ‎01-05-2014

G430 Can no longer hear myself in headset

When I got the headset I could faintly hear myself in the headset and it sort of amplified any noise in my room. Now it's not there but the microphone is still working properly. Is there any way to fix this so I can hear the sound in my room again?

Retired Logitech Employee / Moderator (Inactive)
Posts: 4,496
Registered: ‎08-02-2012

Re: G430 Can no longer hear myself in headset

Hi TwentyEightDays,


n order to assist you better, could you please let me know which Operating System you currently have? Which Logitech Gaming Software version you currently have installed?


Meanwhile, could you please try the following with your Logitech G430 Surround Sound Headset:


1. Open the Device Manager and expand the Sound, video and Game controllers section.
2. Right click on the Logitech G430 headset and select uninstall.
3. Unplug the G430 and restart the computer.
4. After the computer boots up, plug the G430 into a different USB and wait for the drivers to automatically reload.
5. Once the drivers are installed you should get a message saying "Your device is ready to use".
Clean Install for Logitech Gaming Software:
1. Uninstall LGS from your computer.
2. Download LGS from the G430 Downloads Page and save the file.
3. Access the System Configuration Utility and go to selective startup mode. (FAQ 228)
4. Install LGS from the file that you have previously saved.
5. Check the settings and verify that the are all working properly.
6. Restore your system. (FAQ 228)
7. Launch LGS and check to see if the issue persists.
Please give this a try.
Kind regards,

Support Specialist

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.


Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.