Reply
Logi Nu
Posts: 1
Registered: ‎02-15-2014

G430 can hear myself

Hey guys,

I am using a g430 gaming headset and i have 2 problems.
The first one is that i can hear myself while talking. It is not like there is a delay but it is a bit annoying.
It is not in de devices listen option i already checked that pleasse help!

Further more there is a slight crackling sound when i record/talk it is not a major issue but still.

I am running windows 8 and i installed the logitech gaming software.

Pleasse help

Posts: 7,166
Topics: 20
Kudos: 442
Solutions: 314
Registered: ‎01-21-2007

Re: G430 can hear myself


Rab397 wrote:

Hey guys,


The first one is that i can hear myself while talking. It is not like there is a delay but it is a bit annoying.
It is not in de devices listen option i already checked that pleasse help!



It is a setting in Windows. Try telling it not to "listen to this device". That works for some people.

 

 

__________

MK
I have nothing to do with Logitech, I'm just another customer with time on their hands.
I try to help when the official team doesn't respond.

M570, Cordless Trackball | Cordless Trackman Wheel | T650 Touchpad | M235
K800, K480, K360, K340 keyboards
Webcams HD Webcam C625; QuickCam Pro 9000 | H600 headset
SetPoint: 6.61.15 | Driver version: 5.60.73 | LWS 2.31
Windows 8.1 Update | Windows 7 Home Premium 64-bit & 32-bit


If you find a solution to your problem, mark it as "solved". This can help people who are looking for solutions to their problems.


If you want people to see your message, start a new discussion, do not add to an old thread.

PS I don't do Private Messages. We are here to share information with everyone.
Logi Nu
Posts: 4
Registered: ‎02-15-2014

Re: G430 can hear myself

[ Edited ]

Hey,

I bought this headset couple days ago, theres been some problems but I'm feeling like most of them are because of Windows 8.1 but anyway I had this same problem as you, here is how you can fix it:

 

1. Right click speaker incon on right side of your task bar

2. Select "Playback Devices" (Windows sound settings should open)

3. Right click "Logitech G430 Gaming Headset" and select "Properties"

4. Go to "Levels" tab, there should be 2 sliders one for speakers and one for microphone feedback

5. Set microphone slider to zero / mute

 

 

The “Microphone” volume slider and mute icon control the “sidetone” or voice feedback volume. This is NOT the microphone output volume. Disabling this helped me to get rid of anyoing background noise even when the mic was off.

 

If this does not work, go to "Recording Devices" and G430 mic's properties.

Go to "Listen" tab and check "Listen to this device", save and then uncheck it and save again.

Posts: 7,166
Topics: 20
Kudos: 442
Solutions: 314
Registered: ‎01-21-2007

Re: G430 can hear myself


Jofi wrote:

If this does not work, go to "Recording Devices" and G430 mic's properties.

Go to "Listen" tab and check "Listen to this device", save and then uncheck it and save again.


That's the trick I had in mind.

 

Here's where to find it:

 

Listentothisdevice.jpg

 

The advantage of this tactic is that it doesn't screw up other things you might want to do with the headset.

__________

MK
I have nothing to do with Logitech, I'm just another customer with time on their hands.
I try to help when the official team doesn't respond.

M570, Cordless Trackball | Cordless Trackman Wheel | T650 Touchpad | M235
K800, K480, K360, K340 keyboards
Webcams HD Webcam C625; QuickCam Pro 9000 | H600 headset
SetPoint: 6.61.15 | Driver version: 5.60.73 | LWS 2.31
Windows 8.1 Update | Windows 7 Home Premium 64-bit & 32-bit


If you find a solution to your problem, mark it as "solved". This can help people who are looking for solutions to their problems.


If you want people to see your message, start a new discussion, do not add to an old thread.

PS I don't do Private Messages. We are here to share information with everyone.