Reply
Logi Nu
i486DX2-66
Posts: 4
Registered: ‎05-17-2012
Accepted Solution

G110 media keys not working

When I turned on my computer the next day after installed few Windows updates I recieved multiple BSOD's during reboot and needed to use System Restore. The problem was solved after a couple attempts but since then my Logitech G110 Gaming Keyboard doesn't work properly. The volume bar, play, rewind, mute headphones and all other media buttons do not work. I remember I saw an exclamation mark in device manager somewhere after the first succesful reboot which said I needed to enable the hardware but don't know what exactly. I enabled it and the message was gone. 

 

I reinstalled and tried different software to make this work but without luck I guess. I also installed the Legacy software from both on this website and CD and multiple other previous LGS software but without any luck.

 

I tested this keyboard on my brothers computer just in case it could be a hardware malfunction and all buttons worked without installing any software which could indicate it's a hardware or maybe a software conflict on my computer.

 

I also remember that Windows showed an error after the BSOD reboot saying something like "This USB Device does not work properly because some conflicts" I dunno exactly.

 

Could need some help please :smileyhappy:

Logi Nu
i486DX2-66
Posts: 4
Registered: ‎05-17-2012

Re: G110 media keys not working

/bump

Logi Nu
i486DX2-66
Posts: 4
Registered: ‎05-17-2012

Re: G110 media keys not working

/bump

Moderator
Taylarie
Posts: 452
Registered: ‎11-03-2009

Re: G110 media keys not working

This is a User to User Forum. Logitech employees do respond sometimes, but you may get better results trying to call or email them.

Logi Nu
i486DX2-66
Posts: 4
Registered: ‎05-17-2012

Re: G110 media keys not working

Dear users,

 

I solved this problems by enabling Human Interface Device Acces in Services.

 

Workaround:

 

Go to START\CONTROL PANEL\ADMINISTRATIVE TOOLS\SERVICES or type SERVICES.MSC in start > search bar and search for "HID Input Service"/"Human Interface Device Access"/"HID Input" (there are several different names of this service). Right click to start the service and select start or open it by double clicking on it. Change "Startup Type" to "Manual or automatic" and click on the "Start" option and voila!

 

Thanks to different resources found on the internet and a special thanks to "Keyboard/Mouse media buttons not working (HID Input Service) [FIX]" by  video on Youtube!


 

 

 

pg4
Logi Nu
pg4
Posts: 1
Registered: ‎06-25-2012

Re: G110 media keys not working

i486DX2-66 - Thank you soooo much for posting this!!!

 

This bugged me for weeks now and I could not figure it out. This was my solution as well.

 

pg4