Reply
Logi Nu
Stuart0870
Posts: 2
Registered: ‎04-05-2009

On screen notifications of Numlock/Capslock/Scroll Lock

I have a game that I cannot run in full screen mode because everytime I use the NUMLOCK key to do something ingame (can't remap - don't WANT to remap), the on-screen "NUMLOCK: ON" notification switches me back to my desktop, and for the life of me, I cannot find where disable it.

 

I don't have something called SETPOINT installed, which seems to affect others, and I've closed both G15 keyboard profiler and LCD manager, thinking it may have been something in those doing it.

 

PLEASE tell me how I can turn this simple, but bloody annoying thing off.

-Stuart

Logi Master II
SpecialK
Posts: 1,135
Registered: ‎07-19-2006

Re: On screen notifications of Numlock/Capslock/Scroll Lock

There is no on-screen notification with the G15 software. If I were you, I would run task manager and go through each process one by one. You can usually google the exe name to see who it belongs to.
Logi Nu
Stuart0870
Posts: 2
Registered: ‎04-05-2009

Re: On screen notifications of Numlock/Capslock/Scroll Lock

Cheers, it ultimately turned out to be BTTRAY.EXE - a bluetooth app that should have no reason to inject those messages on-screen that I can tell, I don't use a Bluetooth keyboard, so don't understand why it chose to show me the messages.
Logi Nu
MyRevenge
Posts: 1
Registered: ‎08-18-2010

Re: On screen notifications of Numlock/Capslock/Scroll Lock

Yes man, I recently discovered that, too.

Actually it seems strange that an app like the bluetooth stack displays similar messages...

 

Anyway, here is a solution:

Start -> Run, type "regedit" (without quotes) to open the Windows Registry.

 

Navigate through the registry until you reach the following folder:

HKEY_LOCAL_MACHINE\SOFTWARE\Widcomm\BTConfig\General\

 

Now on the right you'll see a lot of values, search for that named "KeyIndication".

Double click on it, and change the value displayed from 1 to 0.

 

Don't forget to reboot, now it should be ok.

Hope this helps, bye bye :smileywink:

Logi Nu
Sangre1
Posts: 1
Registered: ‎10-03-2013

Re: On screen notifications of Numlock/Capslock/Scroll Lock

I disabled the delay involved with capslock (the notification window still appears though)

by:

1. opening your "system configuration" file (do a search if you need to)

2. click on the "startup" tab

3. disable Logitech Gaming Framework by de-selecting it in the checkbox.

 

Works fine and didn't even require a restart...

I dont see anything else affected by this disable yet.

 

Logitech...this is your baby, fix it.    :smileywink:

Moderator
Taylarie
Posts: 453
Registered: ‎11-03-2009

Re: On screen notifications of Numlock/Capslock/Scroll Lock

This topic has now been closed. If you have the same issue, please post your issue in a new thread.