Reply
Logi Nu
jaydeehobbit
Posts: 2
Registered: ‎02-17-2013

G500 will drop connection for a few seconds then reconnect.

[ Edited ]

I've had my G500 for about 1.5 years.

Recently it started to "freeze up" for a few seconds and stop communicating with the system.

After a few seconds it re-connects.

It will do this very often = let's say every 3-5 minutes or so.

 

The exact same thing happed with my old mouse (MX318 I believe) which is what made me get the G500 as replacement.

 

Since I've had the same problem on 2 separate mice I was wondering if it might be a known issue with a fix.

 

I have tried plugging it into every USB 2.0 and 3.0 I have and problem remains.

 

I didn't make any changes to the hardware or software in the timeframe the problems started.

 

 

Thanks :smileyhappy:

Retired Logitech Employee / Moderator (Inactive)
Pau2108
Posts: 3,808
Registered: ‎08-02-2012

Re: G500 will drop connection for a few seconds then reconnect.

Hi jaydeehobbit, 

 

Do you hear the sound the computer usually makes when you disconnect a USB device, every time the G500 stops working?

 

If you don't, please make sure that the USB port that you are using works properly. You can test it with a different device. If you do, please try to test your G500 in a different computer. In case the issue occurs there, please give a call to our support team. They will help you identify if the issue is related to the hardware and they can check if your G500 is under warranty.

 

 

I really hope that you find this information useful jaydeehobbit, and that everything works out well.

Paulina
Support Specialist

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.

Logitech

Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.

Logi Nu
jaydeehobbit
Posts: 2
Registered: ‎02-17-2013

Re: G500 will drop connection for a few seconds then reconnect.

[ Edited ]

Thanks for your reply Paulina.

 

Yes I do get the "beep" from the PC when the mouse disconnects and again when it reconnects.

Also the lights on the mouse will go off between the beeps.

 

As I said above I have tried every USB 2.0 and 3.0 port with the same problem.

 

Warranty will not work for me as I have disassembled the mouse to look inside (AFTER the problem not before :smileytongue:)

I saw nothing wrong inside but the thing is that after I take the mouse apart it will stop disconnecting for a period of hours or even days before it begins to disconnect again. All I really do is look inside without touching anything and give it a hit with canned air inside. And again this is EXACTLY the same scenario I had with my previous Logitech mouse.

Retired Logitech Employee / Moderator (Inactive)
Pau2108
Posts: 3,808
Registered: ‎08-02-2012

Re: G500 will drop connection for a few seconds then reconnect.

Hi jaydeehobbit, 

 

I'm afraid that our warranty doesn't cover any hardware modifications, and disassembling the mouse falls into that category. Based on the information that you posted, and if the same issue occurs in different computer, there's a really high chance this could be a hardware issue. If you have any questions regarding the warranty please click on the link below, and I would still recommend that you contact our phone support team, that way you can make sure if it's a hardware malfunction.

 

 

I hope you find this information useful jaydeehobbit, and that everything works out well.

Paulina
Support Specialist

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.

Logitech

Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.