Reply
Logi Browser
slyr114
Posts: 19
Registered: ‎01-21-2010

G9x back buttons issues!!

yes, the back buttons work but they go either too far foreward or too far backwards depending on which way i am going, i press either of the buttons once and it takes the browser back at least 2 if not 3 pages. anyone else have this issue or a fix?

Logi Browser
Nighthawk117
Posts: 12
Registered: ‎12-02-2009

Re: G9x back buttons issues!!

Hi

you can try out http://www.highrez.co.uk/downloads/XMouseButtonControl.htm

This can fix the forward, backward and the double click problems.

Now I set button 10 in Setpoint to Generic Button 5, and then in X-Mouse Button Control I set Button 5 to Double Click.

Now my G500 and Double Click works like my old G5:smileyhappy:

Let's hope Logitech will release a new driver soon that fix it.

 

Logi Browser
slyr114
Posts: 19
Registered: ‎01-21-2010

Re: G9x back buttons issues!!

Thanks! that works great! am going to use for now but am looking for a fix that doesnt require me to run anymore software that i have to

Logi Nu
210online
Posts: 2
Registered: ‎01-26-2010

Re: G9x back buttons issues!!

Hi there!

 

I have the same problem with my G9x, but only half-way.

I use the G9x on a desktop PC (Windows XP Pro) and here is how the Back and Forward buttons work for me:

1. Windows Explorer - Flawless (browsing folders from my PC)

2. Internet Explorer - Back button acts like double-pressed / Forward button acts normal (used to act like double-pressed until I reinstalled the Logitech software on a clean boot, as suggested by their customer support as an answer to my problem)

3. Google Chrome - Both Back and Forward act like double-pressed. (which is rather frustrating as this is my usual web browser and I need to use Back/Forward like 1.000.000 times a day)

 

The curious thing is that I tried the G9x on another computer from my household, an Acer laptop with Windows XP Pro, and it works just fine with both Internet Explorer and Mozilla Firefox.

 

I have all my software up to date, latest SP, etc...

 

 

Did anyone find a solution for this problem, that does not involve installing new 3rd party software?!

I'm looking forward for a fix to this nasty behavior of my G9x.

 

 

:: Be happy! ::

>:smileyhappy:

Logi Nu
210online
Posts: 2
Registered: ‎01-26-2010

Re: G9x back buttons issues!!

I found a workaround for this frustrating G9x issue:

Back/Forward buttons work just fine (no double-press behavior) if I turn off the Set Point software (right-click the tray icon > Exit).
This leads me to a simple conclusion: SetPoint 5.20.40 needs to be replaced soon by a newer version THAT DO NOT CAUSE DEVICE MISBEHAVIOR.

 

I hope it helps you too.

Moderator
CharlesB
Posts: 4,203
Registered: ‎07-06-2006

Re: G9x back buttons issues!!

It's actually far simpler than that.

 

Go to your buttons, and instead of selecting "Forward" or "Back", assign "Generic Button" for both.

 

The trick is that applications, like Internet Explorer, look for button presses 4 and 5 as forward and back. So, what happens when you assign 4 or 5 to forward or back in SetPoint is that the command gets doubled up: The application grabs the button press, then SetPoint sends it's assigned function.

 

Forward or Back should only be used in applications that support soft Forward/Back BUT do not know how to look at the mouse's presses (Or, say, you want to assign wheel tilt to forward/back)

Logi Browser
Nighthawk117
Posts: 12
Registered: ‎12-02-2009

Re: G9x back buttons issues!!

Hi CharlesB

 

How do you get the double click to work on button 10 in Windows 7?

I use single-click in folder options, and can only get it to work in combination with X-mouse button control.

 

 

 

Moderator
CharlesB
Posts: 4,203
Registered: ‎07-06-2006

Re: G9x back buttons issues!!

I have a G500 at work, and I just tested double click on button 10, and it worked just fine for me. Are you sure you are in the same profile that your programmed the double click option for? Also, if you can't get the double click option to work right (as in, the double click signal is going too fast for your system), you could always record a macro of a double click, and then assign that to a button

Logi Browser
Nighthawk117
Posts: 12
Registered: ‎12-02-2009

Re: G9x back buttons issues!!

Hi again

Yes I am in the same profile where the double click is assigned.

Mouse speed is set to fast in mouse properties.

Mouse is set to single click in Folder Options.

If Double click is assignet to a button in Setpoint 5.2, it opens a folder and the subfolder or the file in the folder.

My old G5 + Setpoint 4.82 do not suffer from this problem in windows 7

But since the G500 is so good (my best mouse ever) I got no problem with the need of 3rd party software to get work, as it should.

Logi Nu
CamRaiD
Posts: 2
Registered: ‎01-11-2010

Re: G9x back buttons issues!!

I have the same issue