Reply
Logi Nu
Posts: 1
Registered: ‎02-01-2008

Harmony 720 will not charge

I love my harmony 720 but one issue that drives me crazy is charging. The craddle is perfectly even and when I put the remote into the craddle it will not charge. It is almost empty now and I don't know what to do. In the past i put it in and out and in and out and eventually it would charge but now i won't at all anymore. has anybody experienced this ?
 
thanks
claus
 
Logi Guru
Posts: 1,510
Registered: ‎11-30-2007

Re: Harmony 720 will not charge

I'm guessing #11 here would also apply to the 720.


Are you a WannabeFAQreader?
Logi Legend
Posts: 12,382
Registered: ‎08-25-2006

Re: Harmony 720 will not charge

probably...I haven't heard of it for the 720, but it's possible

Samsung LCD HDTV (LN52B750), Comcast X1 HD DVR Cable Box, Panasonic BluRay Player (DMP-BD55), Onkyo Receiver (TX-SR806), XBox 360, Nintendo Wii, SlingCatcher, and Apple TV (64GB 4th Gen.)....all with my Harmony Ultimate Home
Samsung LCD HDTV (LN40B640), Comcast X1 HD DVR, Panasonic Blu-Ray Player (DMP-BD60), SlingCatcher, and Apple TV (3rd Gen.) Monoprice HDMI Switch (HDX-501)....all with my Harmony 900 w/ 2 Blasters

(Note: I am not affiliated with Logitech®, Inc.) Have you seen the FAQ Sticky? Useful Links Definition of Delays
Retired Logitech Employee / Moderator (Inactive)
Posts: 754
Registered: ‎10-05-2007

Re: Harmony 720 will not charge

It's very rare for that problem to affect a 720, but it happens. Call tech support.
Logi Nu
Posts: 2
Registered: ‎08-02-2008

Re: Harmony 720 will not charge

My 720 has the same problem... The cradle's right terminal seems to retract and gets stuck, so I need to jar it free. Annoying, but it works most times.
Logi Nu
Posts: 3
Registered: ‎03-21-2010

Re: Harmony 720 will not charge

I had tried everything suggested and nothing worked.  I ended up solving my problem with my original battery (afetr I ordered a new battery of course which I had not received yet in the mail when I solved my problem).  The battery voltage was 3.7V.  I found a link on the Logitech support site that said an old software problem would not charge the battery if the battery voltage dropped below 3.8V.  I had the most recent software already installed so I discounted it as the problem.  On a whim, I manually charged the battery with a seperate power supply to 3.8V and placed the battery back in the remote.  Now the battery charges and everything is fine.

 

Hope this helps someone else.