Reply
Logi Nu
Lauchstange
Posts: 1
Registered: ‎08-24-2012

G35: How to turn the surround simulation off for single applications?

[ Edited ]

Hey there,

 

I just bought the G35 headset yesterday. I really like it. But there's one point that

disturbs me somehow. When I play a game in surround and I use Skype at the same time

the driver simulates the surround sound in Skype causing the quality to drop a lot

and creating this reverberating sound (Hope that's the correct word) on the voice. Can I turn the simulation off

for single applications like Skype?

 

Sincerely

Support Specialist ★★★★
daleLogi
Posts: 5,964
Registered: ‎01-06-2010

Re: G35: How to turn the surround simulation off for single applications?

Hello Lauchstange,

 

Unfortunately, you can't disable surround sound specifically for Skype only. Maybe you can try the following to help resolve the issue:

 

-Go to the Control Panel.

-Select Sound and click Playback Devices.

-Right click the Logitech G35 Surround Sound Headset and hit configure.

-Go through the wizard and uncheck all of the speakers so that you only have left and right.

-Right click the Logitech G35 Surround Sound Headset again, then go to Properties.

-Click enhancements, and put a check on Channel Phantoming.

 

I hope this helps. :smileyhappy:

 

daleLogi

Support Specialist

 

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.

      
Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.