Reply
Logi Browser
Jdotjdot7
Posts: 7
Registered: ‎06-11-2013

G430 Sound issues

Alright, so I just got this new headset, thought i'd give Logitech another chance after i've had so many issues with their mice. So, out of box, this headset sounded good, installed the drivers, turned on surround sound, now when I use mumble and have another program open, there are issues. The sound doesn't cut out like others have posted, but it does fade in and out, I believe it has to do something with the surround sound.

 

It sounds like when someone talks in mumble, the surround sound will become more vibrant and volume levels increase, then when they stop, 2 seconds later, all the sound fades down to a lower volume with lesser surround sound. This is also accompanied with a pop that signifies the change between the 2 modes. I've checked windows settings, the software settings, everything. Any other thing you would like me to try, or can I be assured that there will be a driver update that will fix this?

Logi Visitor
Mole3Mole
Posts: 27
Registered: ‎06-11-2013

Re: G430 Sound issues

here's hoping :smileyhappy:

Logi Visitor
Mole3Mole
Posts: 27
Registered: ‎06-11-2013

Re: G430 Sound issues

i think it may be an issue between Steam and TS3.  i seem to run non Steam games fine.

Logi Browser
Jdotjdot7
Posts: 7
Registered: ‎06-11-2013

Re: G430 Sound issues

Not for me, I notice this issue even while watching a youtube video in mumble, eg. the voices in the video will sound moreso flat, then someone on Mumble will talk and BLAM Incredible Surround Sound... then 2 seconds later, gone. 

Support Specialist ★★★★
daleLogi
Posts: 5,986
Registered: ‎01-06-2010

Re: G430 Sound issues

[ Edited ]

Hi guys,

 

We would like to collect the following information to help with investigating the issue with the G430 Surround Sound Gaming Headset:

 

  • Does the issue still occur when you have the G430 connected via the analog connections with surround sound enabled?
  • Does the issue occur when the G430 is connected via USB with the surround sound enabled?
  • What is the CPU load when the problem happens? Use the Task Manager to take not of the CPU load.

NOTE: This is for users who have not provided the requested details yet. We would like to get information from as many users encountering the issue as possible.

 

daleLogi

Support Specialist

 

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.

 
Logitech 
    
Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status 
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.
Logi Browser
Jdotjdot7
Posts: 7
Registered: ‎06-11-2013

Re: G430 Sound issues

1. Analog, I do not believe it does

2. It seems to happen ONLY with surround sound enabled, however, with it disabled, I only get the right channel when i'm in Mumble which is farely annoying, other programs seem to still function.

3. My CPU is an i5-3570, it's load when this probelm occurs is about 5-20% typically.

 

As i've said, the headset has okay surround sound, then something clicks in it when someone talks in Mumble that makes the surround sound incredible, then I hear a pop 2 seconds later and it's back to normal. 

Logi Visitor
Mole3Mole
Posts: 27
Registered: ‎06-11-2013

Re: G430 Sound issues

CPU load is normal.

I can't set up the anolog connections to 7.1 in the logitech software  headset is not found.

and it only happens when the USB dongle is in use.

 

when Teamspeak3 is being used is when the issue occurs.  tried reinstalling, playing with the settings, running applications under admin.

Support Specialist ★★★★
daleLogi
Posts: 5,986
Registered: ‎01-06-2010

Re: G430 Sound issues

Hi Guys,

 

Here are some additional steps that we want to request that you try to assist with the investigation of the issue:

 

For Mumble users:

 

For Teamspeak users:

 

  • Disable the Volume Control Plug in (Settings > Plugins > Un-tick Volume Control).

Please post the results after trying these steps.

 

daleLogi

Support Specialist

 

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.

 
Logitech 
    
Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status 
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.
Logi Browser
Jdotjdot7
Posts: 7
Registered: ‎06-11-2013

Re: G430 Sound issues

[ Edited ]

For mumble, I have tried every single thing you have listed, in fact, making sure audio attenuation was off was my first step. It still was having the same issues. I am now using the G430 with a Razer Surround sound driver and using it in complete analog mode and it has had no issues. It is also giving me more accurate surround sound and more clear voices. Please look into your software :smileysad:, i've heard what it can do when it is actually working, I just want it to do that the entire time. 

Logi Browser
Budo
Posts: 5
Registered: ‎09-02-2013

Re: G430 Sound issues

I find it absolutely mindblowing that this issue still persists. It's a gaming headset and can't be used with a VOIP program at all.

 

I'd like to add some more issues to this ridiculous problem:

When watching a youtube video while having teamspeak running the software will randomly decide to swap the left and right channels, an issue only fixable by unplugging and plugging the headset in again.

When running teamspeak and starting steam the headset driver crashes in completely in teamspeak. When starting certain games, same thing. When running teamspeak and starting XCOM enemy unknown there's no sound in the game.

When alt-tabbing out of certain games the driver will flip its **bleep** and the headset will start disappearing and reappearing in the LGS until everything is closed.

 

I've had enough. I'm sending the thing back to amazon. Unfortunately I sent my old G35 to logitech as part of a trade in program, don't know if they would ever send it back. Haven't given me my money either.

 

Does anybody have any recommendations for alternatives that aren't too expensive?