Reply
Logi Nu
xer0hope
Posts: 1
Registered: ‎11-13-2010

G930: I can hear myself in my headset

It is really annoying.   On my old Plantronics headset I would just mute the mic in the system control panel and bam,  I would never hear myself over my speakers or in my headset.   But when I mute the mic now with this headset it disables the mic.

 

What I want is this:   I want to hear all my sound through my headset and use my mic to communicate on Ventrilo.   I do not want to hear myself talking as it is incredibly distracting.  

 

What I have is this:   I hear all my sounds in my headset EXCEPT for Ventrilo (which I have to set to go through my speakers) AND I can hear myself talk through my mic.  

 

Any ideas on how to get ventrilo to go through my headset (I set it up in the ventrilo setup to transmit through my headset to no avail.   I can however hear the binds of me changing channels and such through the headset, but I just can't hear people talk or my own push to talk key click.)  and how to stop my mic from playing what it hears through the speakers without disabling the communicative abilities of the mic?

Logi Browser
Prosthetics
Posts: 18
Registered: ‎10-01-2010

Re: G930: I can hear myself in my headset

[ Edited ]

Try ensuring the headset is set as the default device in Windows sound audio properties.  I've noticed programs are sometimes finicky about this.  Also ensure your headset is on when booting.  I remember when I first got the headset I had an issue when I couldn't head people on Ventrilo, then turned on the headset right when the Windows loading screen appeared on screen (watch for when the wireless receiver blinks on and turn it on then), and this fixed the issue.

 

Adjust the Sidetone value in the Control Panel of the headset and slide it all the way down, also ensure the 'Listen to this device' checkbox is not checked in Control Panel -> Sound -> Recording -> G930 Microphone's properties 'Listen' tab to prevent you being able to hear yourself.

Logi Nu
Khaos1977
Posts: 2
Registered: ‎12-17-2010

Re: G930: I can hear myself in my headset

Even if the  'Listen to this device' is unchecked, we can hear ourselves in the headset or in speakers if we use speakers. I hate that.

Logi Browser
gregthomas22
Posts: 9
Registered: ‎12-16-2010

Re: G930: I can hear myself in my headset

in the g930 "control panel" turn the sidetone slider all the way down. it plays back whatever goes through the mic. as far as ventrillo goes the reason you can hear binds and the like is they are seperate settings to choose what device they use (the binds and speech tabs in setup). the voice and PTT clicks are sent to whatever you have set as the "output device" in the voice tab of the setup menu. make sure use direct sound is checked

Logi Nu
Khaos1977
Posts: 2
Registered: ‎12-17-2010

Re: G930: I can hear myself in my headset

Thanks that corrected the problem... local effect shall be renamed "hear yourself slider!"

Logi Nu
Turbenator
Posts: 2
Registered: ‎08-16-2012

Re: G930: I can hear myself in my headset

with no applications open I can still hear myself through my mic. Windows 7 Ult 64. I have the "Listen to" box unched for the mic but I can still me myself talking. Any suggestions?

Logi Nu
Tha_Donger
Posts: 1
Registered: ‎08-19-2012

Re: G930: I can hear myself in my headset

Bump

I am having the same issue. Win7, box is unchecked, everything updated... annoying as all get out!!! Try talking in vent when you have to listen to what you just said with a 1 sec delay XD

Logi Nu
NoraGe
Posts: 2
Registered: ‎09-28-2012

Re: G930: I can hear myself in my headset

Hi I have a Logitech 600 wireless head-set with the same annoying problem - I can hear in the headphones every word i say.... I followed your advice and it worked! I dont hear myself anymore.

Im very happy. Many thanks!!!!

Logi Nu
LPieslin
Posts: 1
Registered: ‎06-06-2013

Re: G930: I can hear myself in my headset

Thank you thank you - that totally worked!

Logi Nu
thrawn1134
Posts: 1
Registered: ‎08-20-2013

Re: G930: I can hear myself in my headset

I turned the microphone volume in the logitech control panel down to the first bar. now people can hear me and i do not hear my self.