Reply
Logi Nu
Shiggity
Posts: 2
Registered: ‎02-04-2013

G930 Ventrilo Mic Muffled

Recently purchased the G930 headset, and it works fine with one exception. Whenever I try to use to mic to speak over ventrillo, the people I'm speaking with tell me that I sound muffled. None of the voice avatars are turned on, and I'm using the latest version of the drivers, and Ventrilo 3.0.8 on a Windows 7 x64 system. I've tried messing with several settings, but I still come through as muffled. Don't have this issue with my previous headset (Logitech H390). Does anyone know of any settings that may be causing this issue with this headset only?

Support Specialist ★★★★
daleLogi
Posts: 5,759
Registered: ‎01-06-2010

Re: G930 Ventrilo Mic Muffled

Hello Shiggity,

 

Here are some additional troubleshooting steps that you can try that might resolve the issue:

 

  • Launch the Logitech Gaming Software. Click the icon that looks like an equalizer at the bottom of the window. Then adjust the microphone gain level (Refer to image).G930 mute LGS.jpg

 

  • Try adjusting the microphone level in the Control Panel:

-Go to the Control Panel.

-Select Hardware and Sound, then click Sound.

-Go to the Recording tab.

-Right click the Logitech G930 Headset, then click Properties.

-Go to the Levels tab.

-Increase the microphone level.

 

  • Try adjusting the microphone recording quality in the Control Panel:

-Go to the Control Panel.

-Select Hardware and Sound, then click Sound.

-Go to the Recording tab.

-Right click the Logitech G930 Headset, then click Properties.

-Go to the Advanced tab.

-Change the Default format to the highest quality.

 

daleLogi

Support Specialist

 

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.

 
Logitech 
    
Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status 
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.

 

 

Logi Nu
Shiggity
Posts: 2
Registered: ‎02-04-2013

Re: G930 Ventrilo Mic Muffled

I've tried adjusting the levels and that didn't help with the issue. As for the last suggestion of changing the default sound format on the G930, it won't allow me to. It's stuck at 1 channel, 16 bit, 16000 Hz (Tape Recorder Quality).

Logi Nu
keanzu
Posts: 1
Registered: ‎07-14-2007

Re: G930 Ventrilo Mic Muffled

I have the same problem with my g930 mic being too soft.  I have gain turned up to max and the volume in windows up to max as well.  With my cheap junk wired headset I used have to set the +20db gain option in windows.  The G930 doesn't allow for such an option.

 

Win7.  I've checked my advanced properties and as with the previous poster, my default format is locked.

Logi Nu
procdaddy
Posts: 2
Registered: ‎05-08-2013

Re: G930 Ventrilo Mic Muffled

[ Edited ]

I have the same issue. Mic volume is REALLY low.

 

I'm also not seeing the mic light options as you have in your screenshot.

 

I'm on win 7 x64.

 

I've checked everything, even with mic levels at 100, I'm barely getting 1 or 2 bars when talking.

Logi Nu
procdaddy
Posts: 2
Registered: ‎05-08-2013

Re: G930 Ventrilo Mic Muffled

After digging around more in the forums. The screenshots that the techs are posting include options that my LGS does not have. That's very concerning to me. See attached image as I'm using the latest version of LGS and I'm missing options included in the screen above.

 

_2013-05-08_19-42-42.jpg

Support Specialist ★★★★
daleLogi
Posts: 5,759
Registered: ‎01-06-2010

Re: G930 Ventrilo Mic Muffled

Hello procdaddy and keanzu,

 

Try adjusting the voice pitch in the Logitech Gaming Software (Refer to the image) and see if it helps with improving the voice input from the microphone of your G930. Also, test your microphone with the Windows Sound Recorder (Start>All Programs>Accessories) and check the quality of your voice recording.

 

voice preview.JPG 

 

 

The options for "Audible mute indication" and "Mic light" are for the Surround Sound Headset G35 only. Sorry about that. I posted an image for the G35 since I didn't have an image for the G930 at the moment.

 

daleLogi

Support Specialist

 

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.

 
Logitech 
    
Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status 
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.