Reply
Logi Nu
Posts: 4
Registered: ‎10-18-2011

G930 not appearing as a playback device?

I rebooted my pc and g930 doesnt appear as a playback device anymore? and ive uninstalled and reinstalled software. It does appear in device manager as G930. Under sounds does not appear under connected devices, disabled devices or disconnected devices... Ive switched usb ports. NOTHING????

Logi Nu
Posts: 4
Registered: ‎10-18-2011

Re: G930 not appearing as a playback device?

got it to detect FINALLY. but now only stereo mode appears? **bleep** is this? is this why I paid nearly 200 dollars for this?

Logi Nu
Posts: 3
Registered: ‎05-19-2013

Re: G930 not appearing as a playback device?

How did you get it to work? I seem to be having a similar issue but I cannot get the thing to appear in playback devices for the life of me.

Logi Nu
Posts: 3
Registered: ‎05-16-2013

Re: G930 not appearing as a playback device?

Please tell us. I got same problem!

Logi Nu
Posts: 1
Registered: ‎05-18-2015

Re: G930 not appearing as a playback device?

Go to Control Panel > Programs > Uninstall a program.  Then right click on the Logitech G930 headset software and uninstall it.  It should then appear in your computer's playback devices and work.  You do NOT have to unplug the headset or the USB from the computer.  For some reason this just works.  I don't have the software on my computer anymore even though when it finished uninstalling I hit the "x" button instead of "finish".  Hope this helps others!!

 

-Mewshiz