Reply
Logi Nu
Pagan_Blitz
Posts: 1
Registered: ‎10-20-2011

Re: G930 sound cutting out

I had al of the above.   I installed the software from logitech's website, and while it did not eliminate all issues, it dramatically improved performance.  At least 95% of he issues I had including the constant cutting out were alleviated.  Can't say if this is a fluke fix, or a lasting impression, but so far, so good.

 

http://www.logitech.com/en-us/441/7248?section=downloads&bit=&osid=14

 

I am running Windows 7 64 bit

Asus G73jh Gaming laptop, latest everything, stock hardware.

 

CHEERS

 

PS, i do not believe that signal interference is so much of an issue, but without any shadow of doubt was playing a role in my problem.  Linksys G router, 2.4Ghz was nearby, my problem DID NOT begin untill i came near it.  Who is to say.  Food for thought.

Logi Browser
B4midabal
Posts: 7
Registered: ‎06-10-2011

Re: G930 sound cutting out

Also had similar problems. I returned the first headset and then discovered same issue with the 2nd headset. I finally found relief. Here's the remedy gleaned from another forum (not Logitech):

"Step 1; rechannel your wireless router from channel 6 to channel one or eleven. The middle bandwith notch for 2.4 Mhz is channel 6.

Step 2; Assumed that wireless setting for G930 would be in the registry: assumed correctly. Enter regedit, go to HKEY_CURRENT_USER\Software\Logitech\G930. There are strings of "bandxgainlevel (where x = 1-10). Band6gain should be reset to 0. It is currently set on some other value. Band5gain should be set to 1. It, also is set to some other value. This must be done after you uninstall the software and driver for the G930, otherwise the registry will simply reset itself."

 

This has worked for me with my games and my music; no skips, no stuttering, no static.

Logi Rook
MeSham
Posts: 66
Registered: ‎08-21-2011

Re: G930 sound cutting out

My Creative HS-1200 wireless headset runs at 2.4 GHz too and in three years it hasn't dropped connection. My G930 is a month old and drops connection every 5 minutes.

 

Logi Nu
Canada42
Posts: 3
Registered: ‎10-13-2011

Re: G930 sound cutting out

Mine has this problem nearly constantly. Played a while tonight and dropped the connection every 2 minutes or so. Upgraded the software and didn't do anything for the problem. Headset is basically unusable for me.
Logi Nu
F1Guzman
Posts: 1
Registered: ‎10-30-2011

Re: G930 sound cutting out

Thanks for this info B4midabal. This fixed it for me!  Man I was already giving up.  I was on my second set from the first RMA with the same issues and was about to call customer support again to negotiate for a swap on the wired G35.

 

I was having the same problems with the sound cutting out when playing games like Battlefield Company 2 and with the new battlefield 3.   By doing this fixed with my Netopia 3347-006 DSL/router, changing the channel ID from 6 to 11 and doing the regedits, all is fine..No more cut-offs..Tested it playing BF3 for a couple of hours and no problems!...Thanks!

 

I had sign-on to thank you for this.  I hope this helps everyone!

 

peace

 

Logi Browser
Kodama
Posts: 11
Registered: ‎01-01-2012

Re: G930 sound cutting out

@B4midabal: I don't find these settings in Win7 x64.

I uninstalled and installed again, but nothing changed.

Logi Visitor
Tides
Posts: 41
Registered: ‎06-14-2007

Re: G930 sound cutting out

[ Edited ]

I used to have minor problems of the cound cutting out every once and a while which was annoying to say the least, especially when having paid so much for a headset when I could have paid half the amount and got a corded set from Corsair.

 

Now with every newer release of the software I get increasing connectivity issues and dropping out issues. It is so bad with the latest 8.20 release that I literally cannot get more than 5 minutes of play in without the USB dongle dropping out of recognition and coming back in again looping the sound from my speakers back to the headset over and over again. I know it is not my headset because with earlier drivers this was not an issue as only the quick cut out of sound was an issue.

 

The drivers for this extremely expensive (double what other quality surround sound with great mics headsets cost) has just gone down hill since the beginning. There has always been crippling problems and now it has got to the point where I have to consider buying a new product altogether (and most definately NOT from Logitech) because I have absolutely no reason to think that this is ever going to improve. In fact from all the evidence of having this headset since launch I know it is only going to get worse.

 

For anyone thinking of buying this headset stay VERY, VERY far away from it. The hardware is superb and the software is so dibilitating that you will want to rage every day dealing with all of th issues with this headset.

 

I am going to try and get a full refund for this headset as it has had defective software since the very begining. This is total garbage and Logitech should be ashamed. I have changed my speakers from Logitech to Creative and I am going to try and get a headset from another company leaving only my mouse left to Logitech.

 

What a dissapointment. Never again Logitech, never again will I buy your garbage.

 

This is on WIndows 7 X64 and has persisted through a fully fresh installation I did when I bought my SSD.

Logi New
madnj
Posts: 5
Registered: ‎09-29-2011

Re: G930 sound cutting out

This has been pretty much correlated to an issue with the G930 and wireless communications on the 2.4GHz band clashing.  I have tested and confirmed that this is exactly what's going on because of the issue being reproducible by setting wireless routers to use specific wireless channels for communications some being better others being worse.

 

If using wired connection, completely disabling any wireless adapters via hardware switch would be advisable.

 

If using a wireless router, test multiple wireless channels and do not set the router to auto.  Personally, channel 9 works best for me.  Some of the lower channels do not disrupt my audio, but disrupt my wireless Internet connectivity.  Some higher channels cutout or I can hear interference.  Channel 9 is best for me, but the issue is definitely related to wireless interference.

 

Unfortunately, Logitech has not/will not published the channel information on what wireless channel(s) the G930 communicates on, so finding the appropriate wireless channel is a bit of trial and error.  I'm extremely happy with my headset, but it took me a good bit of testing to find that channel 9 works well with my device.

 

Hopefully this will help someone else who is having disconnects.

Logi Nu
willjl0
Posts: 2
Registered: ‎07-04-2012

Re: G930 sound cutting out

I rma'd and updated the logitech software but that did not make a difference.

 

After much trial and error, I changed my Verizon Fios router to channel 1 and it no longer drops out. 

 

It was annoying because thier support did not mention wifi could interfere...

Logi Nu
Auroros
Posts: 2
Registered: ‎07-29-2012

Re: G930 sound cutting out

In reply to B4midabal's suggestion that the values "bandxgainlevel" would be wireless settings is incorrect.

 

First of all, to you who can't find them: These values are part of an older software which is only for the G930, and is not for the LGS (Logitech Gaming Software).

 

The values are part of the advanced equalizer, where "1" would simply be +1. This is possible to confirm yourself by changing the values in the old software and refreshing the registry.

 

If you want to try the older versions here they are: x64 x86 However, do not get your hopes up.

 

If the problem is because of Wi-Fi interferance, then there should be a way to change the channel, or isolate it somehow. I live in an apartment and can't really tell all my neighbors to shut down their wi-fis. I am using this headset on my laptop as well as my desktop, but only the desktop experiences the problem. I have cleaned my registry of all that is logitech related, I have reinstalled both softwares, I have tried both and no software. I have tried backports, frontports, high-power ports, low-power ports(USB Hub) and USB3.0. But nothing works.

 

I had this problem before, where logitech decided to send me a new headset without even trying to think of a solution. This headset then worked, but recently I am getting these sound cuttings again. It is really driving me insane. Also, on the note. This problem is causing video to lag as well as the sound. Both on youtube and locally. When the sound cuts, the video stops to catch up.

 

Logitech, get one of your programmers to give the user the option to change the channel manually. The more options the easier troubleshooting. Since the channel is a value within the headset, maybe a firmware update would come in handy as well, you think? I really really love the headset, but a problem like this is not acceptable.