Reply
Logi Nu
Stratimus
Posts: 3
Registered: ‎08-23-2011

G930 sound issues, Surround switch working incorrectly

A couple revisions of software haven't fixed this problem...

 

My G930 has pretty bad sound quality, even with EQ tweaking highs sound really metallic. But I've got a new problem (this happened before updating to the latest software too), my Surround switch isn't working properly. It appears that it's backwards, up gives me surround and down gives me no surround. But the software still detects the right positions. So for example, when I test surround sound in the LGS 8.20.74, I only hear the front left/right because while the software detects I'm in surround, the headset is acting as stereo mode

 

 Anyone else had similar issues?

Retired Logitech Employee / Moderator (Inactive)
dhelpard1
Posts: 654
Registered: ‎03-03-2011

Re: G930 sound issues, Surround switch working incorrectly

Hello Stratimus,

 

Please ensure your headset is plugged directly in to your computers USB port and not in to a pass through device such as a USB hub.  Uninstall your LGS software, download and install the latest version.  If your problem persists, please test your headset on a different computer if possible.  The G930 headset does come with a two year warranty.  If your problem persists please contact Customer Care for your region for further assistance and a possible warranty replacement.

 

I hope this helps you out.

 

Sincerely,

Knowledgebase | Downloads + Get Parts | Contact Support | Manuals | Warranty | Rebate
If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.