Reply
Logi Nu
mjakelsey
Posts: 1
Registered: ‎10-09-2010

H530 not working on Win 7 after update

Hello all,

 

I have a USB headset (H530) that suddenly quit working after running Windows Update (win 7) during the first week of October. 

 

I have tried the following as an attempt at diagnostic:

  1. using a different USB device in this port (a flash drive) with success
  2. using the headset on what I believe to be a different USB bus (back of machine mounted to the mobo) with no success
  3. cursing (many people skip this step)
  4. prayer (multiple deities)

 

Since this headset uses Windows native drivers, I wondering if there is a Windows update that is affecting my ability to use this headset.  Has anyone else run into this?

 

Thanks much!

Logi Nu
Alidah
Posts: 1
Registered: ‎11-05-2010

Re: H530 not working on Win 7 after update

Having the Same issue, I just got a set tonight, brand new and when plugged in everything looks fine. But i get no sound and the Mic doesn't work

Logi Nu
roganr
Posts: 3
Registered: ‎12-21-2010

Re: H530 not working on Win 7 after update

Just bought the USB Headset H530 and plugged up to my windows 7.  Does not work.  Device Manager has it listed under "other devices".  Anyone know of a fix?  Going to return it tomorrow and try another brand if I can find a fix tonight.

Logi Nu
roganr
Posts: 3
Registered: ‎12-21-2010

Re: H530 not working on Win 7 after update

[ Edited ]

Can you go to your control panel/programs and check to see what updates were applied during the first week of October?  This might help us narrow down what the problem maybe.

 

Thanks

Logi Nu
roganr
Posts: 3
Registered: ‎12-21-2010

Re: H530 not working on Win 7 after update

I guess I probably wasted hours of time trying to get this installed. :smileysad:

Logi Nu
84Foxtrot
Posts: 1
Registered: ‎03-15-2011

Re: H530 not working on Win 7 after update

I called tech support and tried several fixes involving the device manager and sound properties.  However, the problem was narrowed down to my installation of Win 7.  I reinstalled Win 7 and the headset works perfectly now.