Reply
Logi Nu
ubercrombie
Posts: 1
Registered: ‎03-26-2011

Logitech G930 turns off 5 seconds after I turn it on...

Tried this on my brothers computer along with mine, still the same problem.

 

Just today I tried turning on the G930 and there was sound coming out of it, then 5 seconds later I hear a nasty buzzing sound (mic was off) and it turns off. It's been repeating like that for the whole day... anyone ever have this problem? Thanks in advance.

Logi Nu
t3r4by73
Posts: 2
Registered: ‎05-17-2011

Re: Logitech G930 turns off 5 seconds after I turn it on...

I'm having the same problem, did you ever find anything out? It doesnt make the noise or shut off if its disconnected from the usb transmitter but as soon as it connects it starts making a terrible noise and turns itselt off.

Retired Logitech Employee / Moderator (Inactive)
kpeppard
Posts: 789
Registered: ‎09-02-2009

Re: Logitech G930 turns off 5 seconds after I turn it on...

Hello all:

 

Thank you for posting to the Logitech Community Forums.

 

Are there any other wireless devices near the G35 or its receiver? If so, remove them and see what happens.

 

Please post with your findings.

 

Regards

Knowledgebase | Downloads + Get Parts | Contact Support | Manuals | Warranty | Rebate
If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.
Logi Nu
Kyou-kun
Posts: 4
Registered: ‎01-14-2011

Re: Logitech G930 turns off 5 seconds after I turn it on...

I have the same problem. In fact, so far I've had about 5 or 6 problems that have rendered the G930 unusable or nearly unusable for at least a few hours to a few days, over the past 7 months. None of the solutions the Logitech support team has offered (including this one) have worked so far.

 

I was simply watching a YouTube video, when I encountered the persistent problem that makes the headphones stop working while doing that, then I replugged them so they would work again and encountered this.

 

This is probably one of the worst products I've ever purchased at the price being offered for it.

Logi Master
NeatNit
Posts: 538
Registered: ‎09-29-2010

Re: Logitech G930 turns off 5 seconds after I turn it on...

I didn't exactly understand what the problem is... Does it also happen if you have the headset plugged in to charge while using it?
______________________
Having weird software troubles, or installation won't work? Test in Clean Boot!
Logi Nu
Kyou-kun
Posts: 4
Registered: ‎01-14-2011

Re: Logitech G930 turns off 5 seconds after I turn it on...

Yes, it does. It makes a god-awful screeching sound and then shuts off about five seconds after it turns on. It randomly turns itself on and off while this is going on, and if I wait a few hours it will sometimes randomly decide to work properly for a while.

Logi Nu
raptram
Posts: 3
Registered: ‎01-09-2012

Re: Logitech G930 turns off 5 seconds after I turn it on...

I know this is old, but I just started having this problem.  How did you fix it?

Logi Rook
jgt1942
Posts: 57
Registered: ‎04-05-2008

Re: Logitech G930 turns off 5 seconds after I turn it on...

What drivers are you (the guys that posted) are you using? What OS do you have?

JGT
Desktop-S4 (Win8.1 Pro x64, 16GB RAM, 12TB (4-3TB Drives, Boot Drive 500GB Samsung 840EVO SSD , Dual Monitors, GeForce GTX470, Motherboard Asrock 990 Extreme 9, AMD Phenom™ II 6 core-AMD 890FX Chipset ), Laptop Lenovo W700 (Win8 Pro x64, 4GB RAM, 1-240GB SSD Boot drive 1-500GB data drive
Logi Nu
raptram
Posts: 3
Registered: ‎01-09-2012

Re: Logitech G930 turns off 5 seconds after I turn it on...

I've been using this driver, since anything newer gives some terrible interference.

 

Windows 7, 64 bit.

Logi Nu
FSchon
Posts: 1
Registered: ‎10-16-2012

Re: Logitech G930 turns off 5 seconds after I turn it on...

You need to do a battery change, you cant start your headset because the battery is burned, this happens if you have your headset connected to the charger while you use it. You should use the headset as little as you can while it is charging, though you burn the positive electrons or something like that.

It´s easy to change, under the soft piece on your left side (not the microphone side) you can find 5 screws, remove them and take off the cover. Underneath that you will find 4 or 5 more screws, remove them and the shell with the Logitech logo will be removable, and there´s the battery.
The screws are small so be sure you have the right size on the screwdriver.

I had the same problem as you, works for 5 sek and that nasty buzz comes and the headset turns off, now it works perfect! :smileywink: