Reply
Logi Nu
Wholesomeflame
Posts: 1
Registered: ‎11-30-2012

My G930 isn't playing audio

It worked the first time I turned it on, then when I unplugged my speakers it turned off. Now with them plugged in and turned on, it's not working. Not even when the G930 is plugged in is it working. Help please?

Support Specialist ★★★★
daleLogi
Posts: 5,960
Registered: ‎01-06-2010

Re: My G930 isn't playing audio

Hello Wholesomeflame,

 

To get your Logitech Wireless Gaming Headset G930 working, try the following steps:

 

-Try plugging the USB receiver directly in to the USB port of your computer. Avoid using a USB hub or docking station.

-Try different USB ports.

-Make sure it is fully charged or has sufficient power.

-Go to the Control Panel>Hardware>Sound>Playback. Make sure the Logitech Wireless Gaming Headset G930 is set as the default audio device.

-Try reconnecting your Logitech Wireless Gaming Headset G930 following the procedures on this link.

 

I hope this helps. :smileyhappy:

 

daleLogi

Support Specialist

 

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.

      
Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.

 

Logi Nu
rossdomke
Posts: 2
Registered: ‎12-05-2012

Re: My G930 isn't playing audio

You have to check your sound options in windows like the supporst specialest said. I have the same thing. I like to listen to my headphones while I am gaming but I like to watch netflix through my speakers and you can really only have one on at a time unless you set it for each specific application (which you can't do in all of them). But if you are using windows 7 I have a little scipt I wrote myself that I put on my task bar (I can upload it if you want to give it a try), or I there are some other solutions that people have posted for switching audio devices with a shotcut key like here.