Reply
Logi Browser
Shadowz01
Posts: 7
Registered: ‎03-02-2011

(Solved) G930 Static/crackling sound problem

[ Edited ]

Finally recieved my G930 yesterday, enjoyed the sound quality for the first 30 seconds and then the static/crackling sound started to join the play every 10~20  seconds.  I've tried it on my netbook without installing software and it worked fine with no static and crackling sound.  But when i switched it back to my desktop the static sound appeared again, so I tried to uninstall its software and the extra noise are gone or well reduced.  Installed and updated to the latest driver and software, the extra noise appeared again...:smileymad: 

I've been searching the forum and tried everything but seem no help =/

Can anyone post up any possible fix or succeeded case? thanks

Logi Browser
Shadowz01
Posts: 7
Registered: ‎03-02-2011

Re: G930 Static/crackling sound problem

popping/static/crackling sound disappeared after I turned off the G930 software but it sounded horrible...

So after working on it for another 30 mins (pretty pissed from the sound, it's killing my ears)

I re-opened the G930 software > closed all the programs that's running in the back one bye one such as antivirus, core temp... etc.. and reopened them. 

In my case here, I've found out SuperAntispyware was what gave me the popping/static sound.  Now all these popping sound are gone after I closed SuperAntispyware.  So to all of you who may be facing the same crap, try closing all the background  programs one bye one and see does it help.  I'm guessing it's G930 software's problem.  I HOPE logitech will do something about it.

 

(Dang I even bought a powered USB hub for $40 but it didn't help)

Logi Nu
Phillv
Posts: 1
Registered: ‎06-01-2011

Re: G930 Static/crackling sound problem

I also suffer from issues like clicks in the sound or small pops which are highly annoying... Have tried by turning of other applications but it doesn't seem to do the job.
Anyone else have an idea why this crackling sound occurs?

Retired Logitech Employee / Moderator (Inactive)
kpeppard
Posts: 789
Registered: ‎09-02-2009

Re: G930 Static/crackling sound problem

[ Edited ]

Hello Phillv:

 

Thank you for posting your issue to the Logitech Community Forums.

 

If the above steps that Shadowz01 suggested did not work then try, for troubleshooting purposes, installing the headset on another computer to see if you get the same results.

 

Regards

Knowledgebase | Downloads + Get Parts | Contact Support | Manuals | Warranty | Rebate
If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.
Logi Browser
B4midabal
Posts: 7
Registered: ‎06-10-2011

Re: G930 Static/crackling sound problem

I don't know this for certain, but there have always been conflicts between audio ( especially 5.1 and 7.1) and intense graphics. These conflicts manifest in various ways, one of the most notable is static/crackling. One of the possible solutions is rearranging applications. For example, you might try uninstalling your G930 software, then uninstall your graphics driver. Reload your G930, then reload your graphics driver. Sometimes the conflict is that more stable drivers "resent" the new kid on the block, and they'll harass him. BTW I have the same issues as all of you, so I'm experimenting, as well.

Logi Nu
Mike930
Posts: 4
Registered: ‎07-28-2011

Re: G930 Static/crackling sound problem

[ Edited ]

Any other tips on how to solve this problem? Got the set for 6 months now and 2 of my friends as well. We all have similair problems. I'm getting really annoyed with the thing now. I tried reinstalling the drivers as administrator and running it as administrator. The weird thing is that the popping sounds and loosing connection doesn't allways happen. Sometimes i don't hear it for 2 or 3 weeks and now i'm listening to popping noises and losing connection for 2 weeks again. I moved the wireless stick to a usb port that is quite far from the other ports to rule out interference but no joy. I hope that logitech fixes it soon...starting to think of getting rid of it and buy the new razer headset. Or a non wireless headset. This is ridiculous

Logi Nu
Belgeron
Posts: 3
Registered: ‎12-04-2011

Re: G930 Static/crackling sound problem

[ Edited ]

I got the same problems as described above, since i have the headset (for 1 week now!) i got those cracking sounds which really kills me!

 

I tried different USB Ports, no Hub, with a HUB nothing helps... Everytime when i have a high CPU Peak, the screen freezes for 1sec. and i get this grrzzztt sound. When i unplug the headset and use my Creative X-FI with the 5.1 Audiosystem i haven't had that problems ever before.

 

I will plug in the USB Device and remove the X-FI and disabled onboard sound, too - still crackling noice.

 

So i used google :smileyvery-happy: and found this thread. I'm using McAffee Antivirus 2011 instead but i also tried what the TE has done, disabled Realtime Scanning - Crackling sounds are gone from that second on. Newer had a problem or 1 sec. screen hanings again.

 

So this really seems it's a logitech software problem (using the latest software here from the site), i hope you can fix that in a near future release.

 

Logi Browser
Ra1dMaX
Posts: 11
Registered: ‎01-30-2012

Re: G930 Static/crackling sound problem

[ Edited ]

this problem is far from solved when the only option to not get the crackling sound is to turn off the software to the headset

got the headset today

 

tried everything in about 3 other posts on different forums pretty much tried every USB port on my comp incl a USB 3.0 powered hub connected to a USB 3.0 port. moved the "hockey puck" away from my other wireless components

tried to do a search and destroy of the background programs even reinstalled the software a couple of times with reboots after ununstalling and after reinstalling without any luck the crackling noise still persists

 

only way to get rid of the crackling is to actually plug in my old Creative HSB1k headset....

BUT i DIDNT SPEND 100+$ to use my old headset

 

LOGITECH GET YOUR ACT TOGETHER AND FIX THIS AS IT IS A SOFTWARE PROBLEM NOT A HARDWARE PROBLEM

 

turning off realtime scanning of MSE is out of the question as i'm not the only user of the computer

Logi Nu
kc5169
Posts: 3
Registered: ‎10-04-2012

Re: (Solved) G930 Static/crackling sound problem

Solution is to change your wireless router's channel to 11.

Logi Nu
ZOEGA
Posts: 1
Registered: ‎10-08-2012

Re: (Solved) G930 Static/crackling sound problem

[ Edited ]

Well... What if you don't have a wireless internet connection? :smileytongue:

I've bee having this problem for about 2 weeks now (Since I bought the **bleep** thing)
I notice the cracks & pops are more audible the higher qualtiy the sound files are.
TrueHD is the worst, but also lossless audio files of 30MB and greater are a big pain in the **bleep**...

I've tried, changing USB sockets, formatting and reinstalling PC, installed head set as FIRST priority (No difference)
Changing the USB response frequency from Win7 standard(125) to 1k.. No change. Repositioned the USB dongle to every possible location... NO change. This is getting VERY annoying!