Reply
Logi Browser
xPreatorianx
Posts: 5
Registered: ‎03-22-2011

Re: Static noise on Logitech G35 headset

But the question is does the headset work with movies, music, and youtube videos on your end? Some of my games work with it if they are compatible and allow 7.1. But everything else glitches like crazy. Which is due to what I sad above. As soon as I take the GPU out it fixes itself. So it's a compatibility issue between the GPU drivers and logitech drivers.

Logi Nu
poohsito
Posts: 4
Registered: ‎07-02-2011

Re: Static noise on Logitech G35 headset

[ Edited ]

yea it works fine with movies, music, and youtube and all of the games play; TW: Shogun 2, Crysis, Battlefield Bad Company 2 (this one is best use of the G35 ever!), Dawn of war 2, Assasins creed 2, Fallout 3, Dragon Age Origins, MW2.  If there's no 7.1 option i choose 5.1.  Using latest cats 11.6 for my 5870 so the Nvidia issue doesnt apply to me.:smileytongue:

 

FYI i dont use the mic on the G35, i use the mic on my logitech webcam pro 9000, so maybe that has something to do w/ it?

Logi Browser
xPreatorianx
Posts: 5
Registered: ‎03-22-2011

Re: Static noise on Logitech G35 headset

@poo**bleep**o - Then your lucky as hell. I've tried everything I can think of short of breaking the **bleep** thing. It's a huge issue just by glancing at this forum but yet Logitech won't address it. It's irritating the hell out of me. The only reason why I still have the headset is because I bought it through Amazon for only $70 IIRC. So if I send it back, I won't be able to get the full retail price to go towards another headset. I might still do it anyways. The sound is annoying and obviously Logitech don't care at all.

 

 

Logi Nu
Duradel
Posts: 1
Registered: ‎12-01-2013

Re: Static noise on Logitech G35 headset


teknogeek1300 wrote:

Ok, here's what you do to HELP the issue.

 

 

 

Go to control panel, open up your Sound options.

 

Go to the RECORDING tab, right-click on "Micraphone - Logitech G35 Headset" and select properties.

 

Go to the ADVANCED tab, lower the Default Format to your liking.

 

 

I can still faintly hear it @ 16,000, but it's MUCH better. HOPE THIS HELPS!

 


Hi this helped heaps.

 

You're right the humming/buzzing sound is still there faintly but its no where near as loud as it originally was.