Reply
Logi Nu
BobbyAbe
Posts: 1
Registered: ‎06-07-2009
Accepted Solution

G35 headset - How do I stop hearing my own speech clearly echo with about one a second delay?

I got the G35 gaming headset and clearly my own speech clearly echo with about a one second delay. Again, the G35 is the USB headset and whenever I put it on and the microphone is on, whenever I talk my own voice begins to get echo'd back to my headset very clearly with a roughly one second delay. It's very disorienting in any conversation to start to hear my own speech a second behind what I'm saying.

 

Any idea how to fix this? Hopefully it's just a simple configuration thing.

 

Please don't respond unless you KNOW the answer and refrain from the "did you try..." stuff.
None of the things I've found like that apply to what is going on for me.

 

Thanks,

Bob

JXF
Logi Visitor
JXF
Posts: 45
Registered: ‎05-07-2009

Re: G35 headset - How do I stop hearing my own speech clearly echo with about one a second delay?

[ Edited ]

BobbyAbe wrote:

Please don't respond unless you KNOW the answer and refrain from the "did you try..." stuff.
None of the things I've found like that apply to what is going on for me.

 


 

Hello.

 

Did you try going into the G35's settings software and turning off preview voice?

 

I hope this helps you.

 

~JXF

Message Edited by JXF on 06-09-2009 06:32 AM
~JXF


Main system: _/G51\__/G35\__/G13\__/G19\__/G700\__/G25\_
Wifes system: _/G9x\__/G15(gen1)\_