Reply
Logi Browser
NetScorpion
Posts: 14
Registered: ‎10-13-2007

A successful installation of the Logitech MX5000 keyboard on a Vista system with internal Bluetooth

I realize this has become a rather lengthy read and for that I do apologize, but see no way to be thorough and not make it rather wordy.  Long story short, I came to the conclusion the problem I was having was linked to my PC's internal Bluetooth solution conflicting with Logitech's. For those not interested in all the problems encountered following the included instructions, the second last heading below entitled "Making the installation work" details just a successful installation.
 
I have noted that very few people who have written in regarding MX5000 installation issues mention their system configuration details.  These details can be very necessary in determining precisely what problems each person is having.  Those that have posted issues and are getting no replies might consider reposting with more details on their system configuration and the exact problem they are having.  Posts that say "I can't get it to work, what's wrong?" simply can't be replied to.  I have tried to recall/include as much relevant detail as I could in hopes that this document might help someone else not go through the four plus weeks of torment I have endured attempting to get this setup to function correctly.
 
Computer System:
HP Pavilion m8150n - 2.6MHz Quad core Intel CPU
Asus motherboard with 3gig RAM and built in Bluetooth
Operating System Vista Ultimate 32bit
All current Windows Updates have been applied, including the recent MS update for Bluetooth.

Overview:
I own two of the above mentioned HP computer systems and purchased 2 identical MX5000's to use with them.  They did not come with the Setpoint 3.3 driver CDs for Vista, so 3.3 had to be downloaded.  The downloaded drivers installation wizard would not complete, even after multiple attempts using the Logitech sites instructions for Setpoint clean removal and safe reinstallation.  Installation attempts were also made using the hard to find but available Setpoint 4.0 drivers, which by the way do not seem to include the separate Desktop Manager that comes with 3.3, but had the exact same disappointing results.  I also tried using different USB ports for the Bluetooth dongle with no success.
I wrote to Logitech support September 7, 2007 with details of all that had been tried, only to get a reply assuring me these keyboards were indeed Vista capable so it must be an HP issue, and suggesting I go to the Logitech site and follow the clean removal and reinstallation procedures.  I replied to this email explaining once again how I had already tried this before initially writing to them, but I never did get another reply.
 
A week later I returned these first two MX5000's and repurchased two more that came with the Vista label on the box and a CD with Setpoint 3.3 drivers, with identically disappointing results.  I contacted HP support who told me the problem is obviously a Logitech Setpoint driver issue since all system functions return to normal after it's removal, and suggested a complete reformat and reinstallation of my new PC just to assure no lingering issues remained from the failed installation attempts.  Since they seemed unwilling to support my PC's further unless I followed this advice, I reluctantly agreed to perform the system restoration back to purchase date defaults.  I then decided it was time to document all I had been through without much help from either company, along with my own thoughts and eventual solutions for all this.

Notes on failed installation attempts:
Following the installation instructions that came in the box, I plugged in the Logitech Bluetooth dongle and turned on the keyboard and mouse which allowed instant and seemingly flawless basic functionality of both.  In all Setpoint installation attempts the Setpoint wizard software failed to complete on it's own.  Manual recognition of the keyboard and mouse was required using the Control Panels Bluetooth Devices window, after which the Logitech BT dongle could be removed as instructed allowing the internal BT solution to be the sole link to the keyboard and mouse.
 
However after finally completing the installation this way, the PC's sleep mode ceased to function, there is no access to CMOS using the BT keyboard, the operating system randomly freezes solid with no keyboard or mouse control, or enters a "blue screen of death" mode requiring a forcible shutdown to recover.  Also the keyboard would tend to occasionally repeat characters, and the mouse would take on a mind of it's own where a small movement would see the cursor continue to flit uncontrollably around the screen for several seconds.  I noted the online removal instructions made no mention of the Logitech driver KHALMNPR.EXE which I discovered resides in the Run entry of the system registry (HKLM-Software-Microsoft-Windows-CurrentVersion-Run), an entry that Setpoint removal from Add/Remove programs in Control Panel failed to clear.  Also Logitech entries in the Bluetooth Devices (or Device Manager under the 'Keyboards' or 'Mice and other pointing devices' headings) were not cleared nor was it suggested to do so in the online cleanup information.  There are other registry entries left behind but they don't seem to matter.  I noted that once all Setpoint software and the rouge entries mentioned above are found and removed that once again there was full trouble free functionality of the system using it's original RF (radio frequency) keyboard and mouse.
 
Just prior to the complete format and reinstallation of my PC I chose to try uninstalling rather than just disabling the internal Bluetooth device.  I began with removal of the software for the internal Bluetooth found in Vista's version of Add/Remove programs now called Programs and Features, then in Device Manager chose Uninstall instead of just Disable for the main Bluetooth Module.  After doing this, the Setpoint installation wizard completed without problems using the supplied Logitech dongle, both the keyboard and mouse appeared to function correctly, Sleep mode continued to function, and I was able to enter CMOS using the  keyboard.  I did not test it like this for very long.  I disabled the internal Bluetooth on my second machine, plugged in the Logitech dongle and installed using Setpoint 4.0 which again errored, but after playing around with manual recognition of the keyboard and mouse and multiple reboots got the system working.  This system would enter sleep mode okay and had CMOS access, but the Setpoint drivers failed on a semi regular basis and needed manually reloaded (run).
 
After a reformat and reinstallation of my initial PC, I began by finding the internal Bluetooth hubs software in Vista's version of 'Add/Remove programs' now called 'Programs and Features' and uninstalled it.  Then I entered the Device Manager and under the 'Bluetooth Radios' heading selected the Properties of the (internal) 'Bluetooth Module'.  From here I selected the 'Driver' tab and clicked the 'Disable' then the 'Uninstall' button.  After completing this I rebooted just to be on the safe side and noted that the 'Bluetooth Radios' entry no longer existed in the Device manager listing.  I plugged the Logitech Bluetooth dongle into the port I intended to leave it in permanently and turned on the keyboard and mouse.  From here I performed another reboot to confirm that the keyboard would again access CMOS which it did.  From here I inserted the Setpoint 3.3 driver CD and ran the installation wizard which completed far more quickly than I have become accustomed to, and requested I reboot to continue.  After rebooting I received a Driver Software Installation error message from the Notification area for the Bluetooth wireless hub.  The Setpoint wizard came back automatically and moved on to the next screen requesting I push the Connect button on the mouse.  After doing this I was taken to a screen which asked me to click the open link of a chain to complete the mouse connection and was then given a Connection Confirmed, Congratulations window that asked me to push Next to continue.  I was then asked to press the Connect button on the back of the keyboard which led to setting the passkey for it.  After enabling the keyboard, the wizard completed showing a screen that indicated successful installation of both devices.  Finally I got a message from Logitech asking me to register my device.  Sadly, the mouse took on a mind of it's own again flitting around the screen for up to 5 seconds after the smallest movement, and the keyboard hung or repeated characters.  So since that did not work, I reinstalled my PC and started again.
 
After the reinstall, I tried to manually connect the devices using the onboard bluetooth (not using the Logitech dongle at all) before loading the setpoint software.  The Logitech mouse and keyboard connected to the existing onboard bluetooth without issue but again the Setpoint Wizard software froze the system and would not install.  Since that did not work either I again completely removed the keyboard and mouse.

Making the installation work:
This paragraph assumes you have attempted to load the Logitech software and not fully reinstalled your computer since.  If you have fully reinstalled you can skip to the next paragraph.  First remove the Logitech software from Programs and Features, those should be both Setpoint and Desktop Messenger.  Then any remaining Logitech entries in Device Manager under 'Keyboards' and the 'Mice and other pointing devices' are removed.  Next the Logitech folders 'C:\Program Files\Logitech', 'C:\Program Data\Logitech' and 'C:\Program Data\Logishrd' are deleted.  If any of these are not found not to worry, as long as none exist before continuing.  Finally, there will be a file called KHALMNPR.EXE found in the RUN command (HKLM-Software-Microsoft-Windows-CurrentVersion-Run) that should be removed.  Of course if you are not familiar with messing around in the Registry you should ask a techie friend for assistance, as this is a VERY dangerous place to play if you are not aware of the dangers.  Finally do an Advanced search including non-indexed, hidden and system files in the C: drive for KHALMNPR.EXE to assure that it no longer exists anywhere, and if it does you should try to delete those also.  If it goes for you like it did for me, you are probably not allowed to delete all the found files which generally means that even after all these efforts to remove the failed Logitech Setpoint installation a core Logitech file still exists and is still being loaded by the system on reboot.  I tried both diagnostic and safe mode boots, but was still unable to delete the copy of the file found in the Drivestore area.  I know for a fact that after a system reinstallation this file does not exist, and mine showed a time and date stamp that coincided with my first installation attempt.  There are also other Logitech folders and registry entries that also remain behind after the programs removal, but luckily they don't seem to interfere with making the final installation work.  I also noted during the tests that the keyboard tends to retain a 'memory' of past attempts, so it would be best to now remove and reinstall the keyboards batteries before continuing.
Now we are ready to try the reinstall.  Disable the internal bluetooth in Device Manager, then with the keyboard and mouse turned off and the Logitech dongle still in the bag (not plugged in) install the software.  The software install wizard will complete without asking for any devices.  Then re-enable the internal Bluetooth in Control Panel's Device Manager and reboot.  After reboot is complete physically turn on the mouse and manually connect it from Control Panels Bluetooth Devices, not allowing the selection of a passkey then pressing it's Connect button while the program searches for the device.  Once recognition is successful, do the same for the keyboard but this time allowing a passkey to be auto-selected and again press the keyboards Connect button while the program searches for a new device.  After entering the passkey I found my system once again froze forcing a power down.  During the reboot there was again no CMOS access, however this time both the mouse and keyboard were seen and appear to work correctly.  From here I programmed both devices and tested Sleep mode which still did not work.  It comes close to entering sleep mode, but just at what would be the final hard drive access before total sleep it reawakens.  After rebooting I again tested CMOS access not surprisingly which still did not work but the keyboard and mouse now both seem to be working correctly.  There are no repeated keys and the cursor only moves the when I move the mouse.  If the keyboard does not recognize don't despair, just remove it from the Bluetooth devices again, physically turn it off and remove the batteries for a minute.  Then reinstall the batteries, turn it back on and try redetecting.
 
I have since followed this exact procedure on a second PC that had been previously been flakey while using the Setpoint 4.0 drivers with the Logitech dongle and has never been reformatted since the first failed keyboard installation attempts.  During this installation the keyboard also froze this system when the passkey was enabled, but on reboot the keyboard was recognized and continues to work perfectly.  Sleep mode and CMOS access again are not available, but those features are simply not as important to daily use as are the connectivity of all my Bluetooth devices.  I can always go back to the original RF keyboard and mouse if I need to get into CMOS.

Final thoughts:
There is a Logitech blog page that explains the different bewtween HCI mode and Embedded mode but only claims to be valid info for operating systems up to XP so I guess I can't fault it for working backwards for me.  Basically it seems to state that HCI mode is required to run other Bluetooth devices. This is where the Logitech Bluetooth dongle is inserted prior to Setpoint installation.  Well when I did the install this way with my Vista system after having removed the internal Bluetooth, I had no success connecting to other Bluetooth devices.  When I left my internal Bluetooth active and installed in Embedded mode where the Logitech Bluetooth dongle is not used, I was able to use my other Bluetooth devices.
 
It was disappointing to have never gotten another reply from the Logitech Support representative, and equally as disappointing to have the HP tech supervisor insist that I reinstall a brand new system before they would be willing to continue supporting it.  Just as a matter of interest I only followed those instructions on one of the two PCs.  I won't be wasting my time contacting either support group again any time soon.  I am pleased to now have my MX5000 devices working correctly while keeping access to other Bluetooth devices, (cell phones and PDAs), using the internal bluetooth hub.  When using the Logitech Bluetooth dongle those other devices were not able to be recognized, and when using the internal Bluetooth hub with Setpoint drivers there is no CMOS or sleep mode access.  There is a Windows Update patch from Microsoft regarding bluetooth device failures after entering sleep mode, but it seems it's not really ready for release yet.  They suggest that unless you are having serious problems that you await its final release in the next Vista service pack.  To be perfectly honest sleep mode is just not all that important to me, so I've just chosen to disable my system from automatically entering it and not use that keyboard key again.  Seems a fair trade-off to get full functionality of the MX5000 devices.  Since I was able to replicate this exact procedure on more than one system I am fairly confident that it actually works and was not a fluke.  If anyone with a similar configuration is still having issues I would be more than happy to take a stab at helping you solve them.
NetScorpion