Reply
Logi Nu
DarthStumpy
Posts: 1
Registered: ‎03-14-2010

Cordless Wave Keyboard not working

I bought the Cordless Wave keyboard and mouse combo (M/N Y-RCP140) today, and the mouse worked immediately but the keyboard did not. Even after installing the latest Windows 7 64bit drivers for the device the keyboard still wouldn't work, and it doesn't even show up in device manager or in setpoint settings.

 

I thought it was a connection problem, but when I look at the instructions on how to connect the keyboard, it tells me to press the red connect button under the receiver, and then quickly press the button under the device. Problem is, there is no button on the receiver that I can see, and just pressing the button on the keyboard causes the power light on the keyboard to flash a few times, but it still won't work. Am I missing something obvious here, or what?

Logi Nu
cowinhand
Posts: 1
Registered: ‎07-10-2011

Re: Cordless Wave Keyboard not working

Have the exact same issue. How can you follow the dirretions of how to connect the wireless keyboard to the wireless USB receiver if the instructions do not match the hardware supplied?

Retired Logitech Employee / Moderator (Inactive)
Cintech
Posts: 3,154
Registered: ‎04-01-2011

Re: Cordless Wave Keyboard not working

Hello cowinhand,

 

 Please provide the M/N and P/N located on the bottom of the keyboard . Is this your keyboard and mouse ? http://www.logitech.com/en-us/keyboards/keyboard-mice-combos/devices/7306

 

Regards,

Knowledgebase | Downloads + Get Parts | Contact Support | Manuals | Warranty | Rebate
If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.
Logi Nu
Kaxben
Posts: 1
Registered: ‎03-31-2012

Re: Cordless Wave Keyboard not working

Me too, I have the same problem, my mouse worked immediately but the keyboard did not and when I press the red connect button under the keyboard causes the power light on the keyboard to flash a few times and the nothing it still won't work.

 

I'm frustrated