Reply
Logi Nu
Adam14
Posts: 3
Registered: ‎01-06-2012

G500 Gaming Mouse Tracking

Hello,

 

I've had a G500 gaming mouse for a few months now and it's been awesome, but a little while ago it started having tracking problems.

 

The problem started as a small amount of lag after lifting to mouse off of the mouse pad.  After put the mouse back down it would take a second or so before it responded.  Now the mouse also is not tracking well when moving it quickly.  I have tried reinstalling SetPoint, but it did not help.

 

I use 5 DPI settings (1600,1800, 2000, 2200, 2400) and a report rate of 1000.  I have tried different DPI settings and report rates, but the problem persists.

 

I have tried cleaning the sensor with a cotton swab and compressed air.

 

The mouse doesn't ALWAYS have tracking problems, but the frequency and severity has been increasing.  It has become an extreme annoyance.

 

Has the sensor started to fail, or is there something I can do to fix it?  This mouse was working perfectly before so it's not due to the mouse pad.

 

Thanks for the help.

 

 

Retired Logitech Employee / Moderator (Inactive)
ebona
Posts: 451
Registered: ‎02-07-2011

Re: G500 Gaming Mouse Tracking

Hi Adam14,

 

Have you tried switching usb ports?

You should try that, if you're still having problems you should contact customer support in your region. The mouse may be having problems.

Regards, 

Knowledgebase | Downloads + Get Parts | Contact Support | Manuals | Warranty | Rebate
If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.
Logi Nu
Adam14
Posts: 3
Registered: ‎01-06-2012

Re: G500 Gaming Mouse Tracking

[ Edited ]

Yeah I tried that... No difference.

 

Thanks though.

 

EDIT:  Seems that it is my mouse pad that is the problem.  I tried the mouse on another computer and it tracked perfectly on a black finished wood desk.

 

I'm using the Razer Sphex mouse pad.  It worked great before... Not sure why it no longer tracks well now...

 

EDIT: Tried cleaning the pad, but still the tracking is terrible.  I'm totally baffled.

 

Please recommend some good pads for the G500!  Thank you!

 

Another EDIT:  Took the mouse to a computer store and tried it on numerous mouse pads.  Those that worked at all had the same problems to greater or lesser extents.  Conclusion: Sensor is intermittent. Contacted CS for replacement.

Retired Logitech Employee / Moderator (Inactive)
ebona
Posts: 451
Registered: ‎02-07-2011

Re: G500 Gaming Mouse Tracking

[ Edited ]

It does sound like it is intermittent. It should have no problems with the Razer Sphex mouse pad.

I use a Steelseries cloth pad (which needs to be cleaned) and mine even works fine with that.

Glad to hear you are getting a replacement! 

Knowledgebase | Downloads + Get Parts | Contact Support | Manuals | Warranty | Rebate
If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.
Logi Nu
Adam14
Posts: 3
Registered: ‎01-06-2012

Re: G500 Gaming Mouse Tracking

The guy I talked to at the computer store was completely baffled by how the mouse responded to different surfaces and mouse pads.

 

Logitech Customer Support has done a great job of helping me.  Thank you for the help :smileyhappy:

Retired Logitech Employee / Moderator (Inactive)
ebona
Posts: 451
Registered: ‎02-07-2011

Re: G500 Gaming Mouse Tracking

You're welcome!

We're always glad to help. 

Knowledgebase | Downloads + Get Parts | Contact Support | Manuals | Warranty | Rebate
If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.