Reply
Logi Nu
faker
Posts: 2
Registered: ‎08-25-2009

How to disable F keys additional features

[ Edited ]

I want to ask how to disable F mode permanetly in my logitech keyboard (acces 600). I often use F1,F2 keys and it's driving me crazy when word or excel is opened acidentally. Please help me. 

Message Edited by faker on 08-25-2009 03:24 PM
Logi Rook
rigelt
Posts: 75
Registered: ‎06-14-2006

Re: How to disable F keys additional features

[ Edited ]

The solution is easy but a bit odd. Use the function "Keys:Keystroke Assignment" and assign F2, F3 or whatever.

Install uberoptions if the driver doesn't let you assign a new Kestroke to the word (Apps: Documents) and excel (Apps:smileyfrustrated:preadsheets) keys.

Message Edited by rigelt on 08-30-2009 04:42 AM
Logi Rook
rigelt
Posts: 75
Registered: ‎06-14-2006

Re: How to disable F keys additional features

while answering another posting I came to realize that since setpoint 4.6 f-lock default behaviour changed? read here might be of interest to you.
Logi Nu
bytemuncher
Posts: 2
Registered: ‎09-03-2009

Re: How to disable F keys additional features

Hi,

 

After being plagued by this F-mode issue (I prefer the standard F keys) for several years I finally found a fix.  I use a keyboard and mouse combo, and I am happy with my mouse button mappings.

 

Here is what I did to restore normal F key functions and disable Logitech's F-mode "feature" (yeah, right).  Device manager -> Keyboard -> right click -> Properties -> Driver tab -> Roll back driver.

 

This rolled back the driver to Microsoft drivers.  The F keys did not work until I rebooted.  Now all seems great.  I have my mouse with logitech drivers and my Logitech keyboard with Microsoft drivers. 

 

Thank you Microsoft!!  (never thought I'd say that)

Logi Nu
bytemuncher
Posts: 2
Registered: ‎09-03-2009

Re: How to disable F keys additional features

Okay, I am still testing this but this is what I have found.  When waking up from sleep mode the Fmode is disabled so the F keys will do nothing when pressed (using MS keyboard driver).  After pushing the Fmode button they will function as standard F keys again.  To me this is waaaaay better than having some annoying bs application pop up unexpectedly.

 

For now I'm content enough, but it would be appropriate for Logitech to address this issue as I have seen many complaints.  A simple checkbox in the Setpoint keyboard settings "Disable enhanced Fmode keys" or "Standard F keys always on".  Something like that and we're all happy.  I mean, I've seen people installing third party software (uberoptions, etc.) just to fix this.  That's total bs in my opinion.  Come on logitech.

Logi Nu
faker
Posts: 2
Registered: ‎08-25-2009

Re: How to disable F keys additional features

[ Edited ]
rigelt's idea is simple and works fine, but i expected something diffrent, because such solution is not a solution for me. but having no other way i have to use it. thanks rigelt!
Message Edited by faker on 09-04-2009 02:41 AM
Logi Visitor
Krki
Posts: 26
Registered: ‎05-23-2006

Re: How to disable F keys additional features

[ Edited ]

Hi

 

Actual (hardware) solution is very simple: just pinch F mode key out, it pops out very easy,  than stuff small piece of tightly rolled paper in one of keys gap, to prevent few milimeters of key movement when pressed. Put key back on. If it doesn't fit, remove excess of paper.

 

If you ever want to use it again, repeat procedure backwards.

 

Voila, no more annoying key :smileyvery-happy:

 

Regards