Reply
Logi Nu
TomSal
Posts: 1
Registered: ‎06-15-2012

LogiLDA.dll Error on boot

I installed the Logitech software for my MK 710 combo on two of my computers and started getting and error with the LogiLDA.dll file whenever I booted either computer. I did a google search and found a bunch of posts about this error but only one here in the Logitech forums (with no solution) . One suggestions was to remove the file from the boot processes with MSCONFIG so I went in and took a look at it and noticed that it was looking for the file on my C drive. Both of my computers are multiboot systems with the D drive being the boot drive on one and the L drive booting on the other. So there's the problem. The install obviously has an error that writing the wrong drive letter in the registry. My solution was to edit the registry to correct the path and the problem was fixed.

 

I had updated the Logitech software to try and fix the problem with no luck. It's seems to me with the many posts on this issue, most over a year old, this should have been patched by now.   Hope this post will help other with the same issue.

Retired Logitech Employee / Moderator (Inactive)
jam0209
Posts: 226
Registered: ‎03-31-2010

Re: LogiLDA.dll Error on boot

Hello TomSal,

 

 

What is the operating system of your computer? What version of Setpoint are trying to install?

 

 

 

jam0209

Support Specialist

      
Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status
If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.
Logi Nu
TX_hillcountry
Posts: 1
Registered: ‎11-21-2012

Re: LogiLDA.dll Error on boot

I got this error today after Windows 7 update installed Logitech Download Assistant.  After a little registry editing, I found the problem was that the new Logitech entries (including LogiLDA.dll) were incorrectly referenced to the "C:" drive.  My windows 7 is running on the "D:" drive (dual boot).  The Windows update was run from "D:", but it erronously referenced the changes as being in "C:".  Changing the "C's" to "D's" in the registry fixed this problem.

Logi Nu
sloanish
Posts: 1
Registered: ‎12-20-2012

Re: LogiLDA.dll Error on boot

I had the same problem

 

I boot from the G: Drive or C: Drive but mostly G:

 

When I installed my new M510 Logitech mouse Logitech changed the registry value at Value Name:

Logitech Download Assistant

from

G:\Windows\system32\rundll32.exe G:\Windows\System32\LogiLDA.dll,LogiFetch

to

C:\Windows\system32\rundll32.exe C:\Windows\System32\LogiLDA.dll,LogiFetch

 

I manually changed it back. NOTE - there are two places where drive G: is mentioned.

Logi New
djlen
Posts: 5
Registered: ‎02-01-2007

Re: LogiLDA.dll Error on boot

I am not computer savvy and don't understand most of the above.   All I want to know is how to fix this 

error message and please, do so in plain English.    

 

 

Regards,

Len

Logi Nu
UsrNameRejected
Posts: 1
Registered: ‎06-18-2013

Re: LogiLDA.dll Error on boot

Absolutely disgusted with Logitech for not only introducing this problem with poor hard-coding, but then NOT FIXING IT and rolling out a fix, AND INCREDIBLY then NOT SUPPORTING struggling customers on their own forum!

 

In view of those facts, and in the spirit of free help and information for all, here is how to put this shoddy installation right in beginner-speak.

 

Click Start, then Run then type “regedit” and click OK.

 

Navigate the folder structure on the left, to the two locations indicated below, and modify the specific items named, to reflect the drive letter of your current boot drive. I’m guessing it’s not ‘C’ or you wouldn’t be reading this thread…

 

 

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

 

Item name on right hand panel: “Logitech Download Assistant”

 

Change value (double-click name to edit) to “F:\Windows\system32\rundll32.exe F:\Windows\System32\LogiLDA.dll,LogiFetch” where the two references to ‘F:’ are YOUR Windows boot drive letter.

 

 

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\LogiLDA.dll

 

Item name on right hand panel: “Path”

 

Change value (double-click name to edit) to “F:\Windows\system32” again, where ‘F:’ is replaced with your boot drive letter.

 

Hope this helps.

Logi Nu
BafTechGeek
Posts: 1
Registered: ‎07-06-2013

Re: LogiLDA.dll Error on boot

I had the same error message. What my findings was, I started getting this error message once the certificate expired. My certificate only valid upto 4/28/2013. Refer below.

 

cert.png

 

Logi Nu
logankw
Posts: 1
Registered: ‎07-17-2013

Re: LogiLDA.dll Error on boot

I've discovered a possible (correct) solution to this problem. I had the same error on Windows 8 Pro, and my certificate also expired on 4/28/2013 (although I have no idea if that's the core problem). Anyway...

 

1. Go to your device manager in your control panel.

 

2. Expand Human Interface Devices.

 

3. Locate "USB Input Device (Logitech Download Assistant).

 

4. Double-click it to open it, go to the driver tab, and uninstall it. Make sure to check "Delete the driver software for this device" before clicking okay.

 

5. After it has uninstalled, scan for hardware changes. It might take a second to recognize (and there's no prompt of any kind), but it will eventually reinstall the device.

 

6. Restart your computer. The error should be gone.

Logi Nu
win8user
Posts: 1
Registered: ‎10-05-2013

Re: LogiLDA.dll Error on boot

I just installed Win 8 on a newly built PC in which I had installed nothing and I get the following from Win8 RunDLL:

 

"There was a problem starting C:\Windows\System32\LogiLDA.dll"

"The specified module could not be found".

 

Yet the file is exactly where this error says it can't find it. I tried using regedit as specified in this post but found that there is no error in the registry path in either case givien. The drive letter and path are correct. Something else is obviously going on here.

 

Hey Logitech!!! It sure would be nuce if you would fix this.

 

 

 

Logi Nu
sunnyandbow
Posts: 2
Registered: ‎10-18-2013

Re: LogiLDA.dll Error on boot

Hi all, my first post but I hope it helps.  I had the same error after upgrading to Windows 8.1.  There was no error before.  I re-inserted a Unifying USB Dongle into a previoulsy unused USB slot and Windows recognised the new Dongle and completed a full driver install.  Following this I rebooted and the error message had gone and has not re-appeared.  I used the same fix on two different laptops A Dell XT3 and a Dell ST 10 both of which did not have the error withe Windows 8 but did after the upgrade to 8.1.  The fix worked for both.  Hope it will work for you too.  Best wishes and good luck.