Reply
Logi Nu
mc622
Posts: 1
Registered: ‎02-28-2011

Re: MX5500 Mouse Lags/Problem

I have the same problem with the mouse. This is my 3rd bluetooth logitech. I love the keyboard and the feel of the mouse but the functionality is a huge problem.

 

I am a running a quad core processor with 2gb of ram on windows 7 with a wired internet connection. This kb/mouse combo is the only wireless device I have. My phone's bluetooth is not enabled so that does not interfer. I have no other wireless devices and I have no problem with my USB ports (and I have tried front and back with the same problem). I have use the previous USB extention cord and have plugged directly into the computer.

 

The keyboard works about 99.9% perfect. Maybe once a week I will get a key stroke that repeats 10x and stops. This is a huge improvement from my first mx5000 a while ago that saw key strokes being stuck with no way of stopping it other than a hard shut down.

 

My last mouse had big issues. It would just stop working for 10-20 seconds and this would occur many times a day. The unit was passed warrently so I bought this new keyboard in November. The mouse stops working maybe once a day for 5-10 seconds but I have constant lagging issues and have found no way to fix them. And these problems have occurred having this unit in office and in two different apartments... With metal and wood desks!

 

Obviously the issue is just fualty blue tooth connections. I never had a bad connection with the non bluetooth wireless mice and keyboard. Maybe I should just stop using bluetooth and save the money!!??

Logi Nu
matthewyau89
Posts: 1
Registered: ‎01-16-2009

Re: MX5500 Mouse Lags/Problem

Lag problems here too. It's strange too because both mouse and keyboard worked perfectly fine when I first got them. Then the problems occurred and they just get worse and worse with each passing day. Lag on the mouse is absolutely horrendous at times, the mouse could not be any more faulty if it tried.

 

The keyboard also gets problems with keystrokes repeating. Also, my problems seem more frequent then everyone elses. I must have one of the more faulty batches.

 

Furthermore, do people here also experience connectivity issues. My keyboard and mouse have come to point where sometimes, they just will not connect, ever! Perhaps maybe tomorrow they will, but even after multiple hard restarts, they just won't connect. Reinstalling setpoint has allowed me to use the keyboard again, but I am having to use a seperate mouse because the lag problems on the mouse are now constant.

 

It's a shame Logitech have reliability and functionality issues with some of its products (z5500 speakers) because they make such good products, both technically and ergonomically. It's probably why the customer service is soooo good too. Honestly, best customer service in any company I've ever seen which is why I still stand by their products even though some of them have persistent issues.

Logi Nu
TroyM76
Posts: 3
Registered: ‎03-22-2011

Re: MX5500 Mouse Lags/Problem

I am having totally the same problem, and dont want to use the the dongle that came with it, never had to on my last system, only ever had a problem with keyboard before, repeating and having to reset it about once a week, now no problems with keyboard, and all this lag and cutout for 20 seconds with the mouse,

 

Running win 7 64x

Dell Precision M4500

with internal bluetooth

 

also tried disabling power management on the bluetooth moudel with not much luck.

 

Thanks Troy

Logi Nu
davecypher
Posts: 1
Registered: ‎05-11-2011

Re: MX5500 Mouse Lags/Problem

Me too. Windows 7 Pro - quad core AMD- 16 gig memory - wired ethernet - no other wireless devices/bluetooth.

 

Using Photoshop - absolutely frustrating.

 

The problem has been report so often and for so long.

 

Do Logitech really care ????

Logi Nu
aaronp
Posts: 1
Registered: ‎06-14-2011

Re: MX5500 Mouse Lags/Problem

I have been plagued on and off for many months with this lag issue. I think last time i fixed it with driver updates for video, network and mouse. This time, i just changed the usb port the dongle was plugged into and presto, it is now working like a charm!!

 

give it a go...

Logi Nu
ninety-9
Posts: 4
Registered: ‎12-13-2010

Re: MX5500 Mouse Lags/Problem

Glad I saw this before making a $150 mistake.

Logi Nu
drool
Posts: 2
Registered: ‎12-05-2011

Re: MX5500 Mouse Lags/Problem

I just bought the keyboard mouse combo mx5500 and I like the keyboard but the mouse behaves horribly. This thread is calling it "mouse lag" which I believe is also the problem I have. I would not buy this product or any other Logitech product again unless Logitech comes up with a reasonable fix for this problem. I have tried everything in this thread but to no avail so it is obviously a software issue relating to Windows 7.

Logi Nu
TroyM76
Posts: 3
Registered: ‎03-22-2011

Re: MX5500 Mouse Lags/Problem

use the Bluetooth key that comes with it you wont have a problem, as it fixed it for me, i used to just take my mouse with my laptop where ever i went, now i just need to take the USB blue tooth key

 

works 100% once i gave up on trying to use the internal bluetooth on my Dell Precision

 

 

Hope that helps

Logi Nu
Jason_V
Posts: 1
Registered: ‎05-23-2012

Re: MX5500 Mouse Lags/Problem

I wish I had seen this thread before I purchased..

 

I'm having the exact same problem and I've tried all suggested fixes except replace.  When I first installed it I did not have the problem.  The mouse is barely usable in windows and completely unusable for gaming.  I've had to go back to a corded mouse for daily use because it is just too frustrating to have this much mouse lag.  The lag occurs regardless of how fast or how slow I move the mouse.  Yet oddly it can be intermittant, some days the mouse peforms flawlessly.

 

-Frustratedly 

  Jason V.

Logi Nu
Ranke1
Posts: 1
Registered: ‎06-13-2012

Re: MX5500 Mouse Lags/Problem

@Jason_V

 

I so agree. This thread took me 20 minutes to write, because I have the keys typing 10 of the same letter like every miinute.

 

The lag is just permanent, I lost two characters to lag spikes in a game called Realm Of the Mad God.

 

And some days, my comp has no problem doing anything and notthing happens.

 

LOGITECHHHHHHHHHHHH!!!!! HELP ME OUT!!!!!