Logi Nu
Posts: 3
Registered: ‎11-04-2012

k800, no question mark key

I have the k800 and i noticed so far 2 or 3 keys that do not work in the correct manor.


For the question mark key.. i get É instead of the question mark.


And the @ symbol only comes if I use the right alt key in conjunction with the 2 key. holding shift+2 does not work and gives me " instead.


Don`t understand what is going onÉ




Posts: 7,580
Topics: 20
Kudos: 474
Solutions: 326
Registered: ‎01-21-2007

Re: k800, no question mark key

Just a thought, but is this possibly a language thing in Windows?


  • >> Control Panel
  • >> Region and Language
  • >> Keyboard and Languages

Does that look right?




M570, Cordless Trackball | Cordless Trackman Wheel | T650 Touchpad | M235
K800, K480, K360, K340 keyboards
Webcams HD Webcam C625; QuickCam Pro 9000 | H600 headset
SetPoint: 6.67.82 | Driver version: 5.90.41 | LWS 2.51
Windows 10

If you find a solution to your problem, mark it as "solved". This can help people who are looking for solutions to their problems.

If you want people to see your message, start a new discussion, do not add to an old thread.

PS I don't do Private Messages. We are here to share information with everyone.

I have nothing to do with Logitech, I'm just another customer with time on their hands.
I try to help when the official team doesn't respond.

Logi Nu
Posts: 1
Registered: ‎11-29-2012

Re: k800, no question mark key

I am having the same issue - Keyboard language fix did not work