Reply
Logi Nu
zihao
Posts: 1
Registered: ‎02-20-2013

new mk520 mouse doesn't move

This is the mk520 Wireless Combo.(Keyboard: K520. Mouse: M310)


I plug in the USB receiver, the keyboard works well but the mouse doesn't. The mouse doesn't move at all but its left click, right click, and the mouse wheel works okay. I place the mouse on newspaper, smooth table, and mouse pad, but it still doesn't move at all. I try this on my friends' laptops which are also Windows 7 x64. Same problem again, keyboard works but mouse doesn't move. Also, I try different USB ports and install the Unifying Software, it still doesn't move at all.

Support Specialist ★★★★
jc1990
Posts: 4,496
Registered: ‎08-02-2012

Re: new mk520 mouse doesn't move

Hi zihao,

 

Since you already tried all those troubleshooting steps, it seems that it could be a hardware issue. 

 

 I highly recommend that you please place a call to our Logitech Phone Support center to see how we can help.

Kind regards,

Camacho
Support Specialist

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.

Logitech

Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.


Logi Nu
netfanatic
Posts: 1
Registered: ‎12-06-2013

Re: new mk520 mouse doesn't move

Hi I have bought the Logitech Combo MK520 a month ago. The Keyboard works fine but the M310 mouse does not work properly. Once I start my PC the mouse and the keyboard work fine for around 15-20 minutes and then all of a sudden the left click on the mouse stops working. I can only do a right click, scroll and move the mouse but no left click.

I also noticed that after this issue the battery of the mouse also drains quickly. Any suggestions how to fix this. Thanks