Reply
Logi Nu
tough89
Posts: 1
Registered: ‎06-15-2012

Logitech Wireless Gamepad F710 Not Working

I'm trying to install my F710 Gamepad on my Windows 7 Home Premium (64) Bit Dell Laptop. I've tried installing it using the disk, the driver from the website, and tried using the F710 Connection Utility. When I use the Connection Utility it shows up in the Logitech profiler but when I switch to X-Input mode it doesn't recognize the change, when i close the profiler and open it again it doesn't detect the controller anymore. The profiler doesn't detect it when i switch back to d-input mode either. In device manager it shows there's a driver problem with "Wireless Gamepad F710" under the category "Other Devices" even though I have installed the driver from the disk and from the Logitech website. I know my controller still works because it installed just fine on my friends windows vista 64 bit desktop computer and his computer could detect it in either d-input mode or x-input mode. I've tried everything I can think of to make it work but it doesn't want to, can anybody help me? Does anybody know a solution or had the same experience and was able to make it work? Please help! thanks.

Support Specialist ★★★★
daleLogi
Posts: 5,919
Registered: ‎01-06-2010

Re: Logitech Wireless Gamepad F710 Not Working

Hello tough89

 

We have an existing thread regarding a similar issue (refer here). There are some possible solutions on the thread that you can try.

 

dalong

Support Specialist

      
Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status
If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.