Logi Nu
Posts: 2
Registered: ‎10-04-2013

G430 stopped working

Hi, I have had a Logitech G430 headset for a month or 2 now with out any problems, but when I turned my PC on today no sound came through the headset, and when I checked the Logitech device manager it did not pick up my headset, when using the USB adapter or analog connectors, how ever when I use my headset with my phone or xbox it works perfectly, have you got any ideas on how I can get my headset working with my PC again?

Retired Logitech Employee / Moderator (Inactive)
Posts: 4,496
Registered: ‎08-02-2012

Re: G430 stopped working

Hi jdonald,


Since it didn't work with the USB adapter and neither with the 3.5mm cable, then I will recommend to check your Sound Settings in your computer and set your G430 as a default speaker.


However, you might want to try the following too:


  1. Go to your Start Menu
  2. Open Control Panel
  3. Go to Hardware and Sound
  4. Open the Device Manager Option
  5. Scroll down to Mice and other pointing devices
  6. Open the Drop down menu
  7. Select the Logitech G430 and double click it
  8. A window will pop up
  9. Go to the Drivers Tab
  10. Click on "Uninstall" 
  11. Unplug your Logitech G430
  12. Restart your computer
  13. Plug the Logitech G430 once again

Try to set the settings again and check if the G430 is working.


Please give this a try.


Kind regards,

Support Specialist

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.


Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.

Logi Nu
Posts: 1
Registered: ‎10-08-2013

Re: G430 stopped working

I also have this issue and have tried the same things to resolve it, but to avail. I looked in all of the dropdown menus within the Device Manager and then was no entry labeled as Logitech G430; instead, I found a USB Advanced Audio Device. I have tried several times to unistall this device, unplug my headset, and try again to install the correct software, but all it does is repeat the issue, but adds a number to the front: 1-USB Advanced Audio Device, 2-, 3- etc..


I have had 0 issues with this headset until today, and it works on other devices/computers. Also, the Logitech Gaming Software never recognizes my headset now.

Logi Nu
Posts: 2
Registered: ‎10-04-2013

Re: G430 stopped working


thanks for the reply jc1990


i have now found the problem, it was the USB adapter that stopped working along with my bios resetting the motherboard sound drivers,


my headset does work for me now,

Thanks for the help


Logi Nu
Posts: 1
Registered: ‎04-14-2015

Re: G430 stopped working

Hello sir i got the same problem with my Logitech g430 could you help me please?

Logi Nu
Posts: 1
Registered: ‎04-26-2015

Re: G430 stopped working

Hi jc1990,


I have exactly the same problem as jdonald but i can fix my headset.
I tried your solution but he does not reconize my headset as G430 logitech gaming headset.

He says that it is a USB Advanced Audio Device.
I dont know much about computers so i want to ask you if you maybe have an other solution to this problem.



I would be gratefull if you would help me,