Logi Browser
Posts: 7
Registered: ‎10-15-2013

G700s reassigned hotkeys not working in sc2

Working on windows 8.1, but reinstalled LGS and it seemed to be working fine with everything.


Never used hotkeys for sc2 so no idea if it would've worked before 8.1 but I don't think that's the problem.


Anyway, problem is, hotkeys reassigned (1, 2, 3 , 4 ,5 etc) for controlling groups of units, reassigned to the mouse buttons on the side, do not work. They work for other programs, the SC2 profile I made is working (all the other reassigned buttons work, volume, mute, etc). And the function "5" is working when I reassign it for typing for example.


What am I doing wrong?

Support Specialist
Posts: 4,027
Registered: ‎04-26-2012

Re: G700s reassigned hotkeys not working in sc2

Hi dtmwerks,


Have you already tried setting the SC2 profile as "persistent" when you programmed it on your G700s mouse side buttons?




Support Specialist


If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.




Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status 

All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.