Logi Browser
Posts: 6
Registered: ‎04-16-2007

G9x mouse not recognized by SetPoint

I am having the same issue as a previous poster in another thread.  SetPoint 6.32 does not recognize my G9x mouse. I have uninstalled setpoint 6.32 and reinstalled several times.  I have uninstalled 6.32 and reverted to 6.30 and again I get the same message that Setpoint did not detect any supported connections.  I rebooted two more times after installing 6.30 like suggested in another thread, but still no luck. I then let the logitech software upgrade to 6.32 again and mouse is still undetected.  The mouse is seen as Logitech HID-compliant G9x Laser Mouse Call of Duty: MW3 in device manager.  I have installed and run setpoint as administrator, still not working.  Mouse has been plugged into other USB ports.  Any other suggestions?

Retired Logitech Employee / Moderator (Inactive)
Posts: 36
Registered: ‎02-15-2012

Re: G9x mouse not recognized by SetPoint

Hello cpiper,


Ensure you are opening the Gaming version of Setpoint under Start -> All Programs (Programs)-> Logitech-> G9x, G500 and G700 Gaming mice -> Device Settings. I would also suggest removing the mouse from the Device manager, unplug the mouse reboot and plug the mouse back in once you rebooted. If the problem still persists try reinstalling Setpoint in a Clean Boot mode.


You can download the latest software here:

32 Bit

64 Bit



Kind Regards,

Knowledgebase | Downloads + Get Parts | Contact Support | Manuals | Warranty | Rebate
If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.
Logi Browser
Posts: 6
Registered: ‎04-16-2007

Re: G9x mouse not recognized by SetPoint

[ Edited ]

Thank you for your response Meltech.


Unfortunately your suggestions did not work. I uplugged the mouse and rebooted (I had to plug it back in during the boot though in order to pick my account). I then uninstalled the setpoint 6.32 software, did a clean boot reinstall, but the mouse still is not recognized by the software. 


Other suggestions?

Logi Nu
Posts: 1
Registered: ‎03-14-2012

Re: G9x mouse not recognized by SetPoint

Okay I was having this same issue earlier and i checked online for solutions and i was surprised when i didn't find anything useful. 
 It took me sometime but i got this resolved. Here's how i did it; 
1. Download and install latest software from
2. Connect Mouse.
3. Open Software. If not working, (probably won't at this point) Conect another mouse for navigation. Keep G9x connected.
4. Open Control Panel> Hardware & Sound> Devices and Printers
5. If G9x Icon is not there, Refresh a couple of times(F5) and it should detect it>Select "G9x Laser Mouse"
6. Right Click on "G9x Laser Mouse"> Select "Properties"> Click on "Hardware" (Top)
7. Under Device Functions, Double Click "G9x"
8. Click "Drivers" (Top)> Click "Update Drivers"
9. It will automaticall;y update the drivers and the mouse will work again.
10. Open the Sofware application and verify that mouse is detected properly under G9x, G500 and G700 Gaming Mice.
Hope it helps, have fun. Cheers! 

Logi Browser
Posts: 8
Registered: ‎04-11-2012

Re: G9x mouse not recognized by SetPoint

Try removing the KB2529073 Windows update. I was having the exact  same problem, when I unistalled the windows update it works perfectly.  

Logi Nu
Posts: 1
Registered: ‎07-04-2012

Re: G9x mouse not recognized by SetPoint

I registered just to say: Will31 - I want to have your babies. Removing KB2529073 Windows update fixed the issue, cheers buddy!

Logi Visitor
Posts: 22
Registered: ‎07-26-2011

Re: G9x mouse not recognized by SetPoint

That trick didnt work for me on my G700.  Setpoint still wont recognize it but what I did was create a Device Settings shortcut on my Taskbar and after booting into Windows, I right click it and select Run As Administrator.  This always does the trick.

PC gamer & overclocker
G510 • G9 • G700