Logi Nu
Posts: 2
Registered: ‎06-19-2013

LGS: G9X No devices detected

My problem:  I installed a macro onto the G9X that I would like to remove.  When I opened SetPoint it was not detecting the G9X.  I unistalled SetPoint and installed Logitech Gaming Software.  I am still getting the message "No devices detected.  Please ensure that your device is supported and firmly attached to a USB port."  I've tried every single USB port with no change.


I've read some of the similar threads that came up on my search results for the issue none of which worked for my scenario.  I also have not come across any official Logitech supported solution to this issue.


I just want to restor my G9X to the normal default factory settings.  If anyone could help it would be greatly appreciated!


Thanks in advance.  

Retired Logitech Employee / Moderator (Inactive)
Posts: 5,409
Registered: ‎04-26-2012

Re: LGS: G9X No devices detected

Hello TheSKA1230,


I'm afraid that you can only reset your G9x Laser Mouse to its default settings through the Logitech Gaming Software or Logitech Setpoint. In this case, LGS should first recognize the mouse. You can try the following procedure to remove ghosted entries from your Device Manager, which probably prevents LGS from identifying your mouse:


  1. Launch command prompt (Start > type cmd on the search box). Command box will appear.
  2. Run this command: set devmgr_show_nonpresent_devices=1
  3. Run this command to start Device Manager from this Command Prompt: devmgmt.msc
  4. Once the Device Manager appears, click on View > Show Hidden Devices
  5. Unplug the G9x Gaming Mouse (you will need another mouse in this process).
  6. Expand "Mouse and Other Pointing Devices" and "Human Interface Device".
  7. You will see sub-entries with lighter, transparent icons. These are called "ghosted devices". Select and delete all of those entries. Just do it one at a time.
  8. Uninstall your Logitech Gaming Software v.8.46.
  9. Perform a clean boot.
  10. Reinstall Logitech Gaming Software v.8.46.
  11. Plug back the G9x mouse.
  12. Revert to Normal Start-up.
  13. Check if the mouse is recognized in LGS.
  14. Close LGS and restart the computer if necessary to test if the mouse will be recognized even after a reboot.
  15. If LGS recognized the mouse, you can restore it to its default settings.

Try it and see how it goes. I hope this suggestion helps. Feel free to post back for further updates. Smiley Wink




Support Specialist


If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.




Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status 

All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.
Logi Nu
Posts: 2
Registered: ‎10-24-2014

Re: LGS: G9X No devices detected

i have like that problem in my g25 but i don't know how can i fix it please help me