Reply
Logi Browser
Posts: 7
Registered: ‎08-02-2013

g700s No Devices detected

Hi,

 

i recently purchased a G700s and have installed LGS 8.46.27

 

When i launch LGS, it states "No Devices detected"

 

I've tried to uninstall and re-install the driver several times.

 

any help please?

 

thanks!

Logi Browser
Posts: 7
Registered: ‎08-02-2013

Re: g700s No Devices detected

I forgot to mention that i am running Windows 7 Service Pack 1

Retired Logitech Employee / Moderator (Inactive)
Posts: 3,808
Registered: ‎08-02-2012

Re: g700s No Devices detected

Hello jrsl1,

 

To better assist you it would help a lot if you provide me with the information below:

 

  • Does your G700s have regular mouse functionality? Or is it not working at all?
  • How is your mouse listed on the Device Manager?
  • Do you get the error message when using the mouse in wireless mode, wired mode or both?

 

I'm looking forward to your reply jrsl1, I hope we can figure this out soon.

Paulina
Support Specialist

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.

Logitech

Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.

Logi Browser
Posts: 7
Registered: ‎08-02-2013

Re: g700s No Devices detected

 

  • Does your G700s have regular mouse functionality? Or is it not working at all? Yes the mouse has regular mouse functionality, in fact, G10 acts as alt+tab and switches between open programs, G9 acts as a shorcut for windows search, G8 = nothing, and middle mouse = nothing. It's just that LGS states "No Device Detected".
  • How is your mouse listed on the Device Manager? The mouse is listed as HID-compliant mouse. No mention of logitech.
  • Do you get the error message when using the mouse in wireless mode, wired mode or both? Yes, LGS states "No Device Detected" both wireless and wired mode.
Logi Apprentice
Posts: 343
Registered: ‎07-09-2009

Re: g700s No Devices detected

Windows HUD driver is received cause there is no "Switch from Windows to Logitech driver". And Logitech still didn't implement this feature in v8.46

 

http://forums.logitech.com/t5/G-series-Gaming-Mice/LGS-8-46-is-available-to-download-install/m-p/104...

Logi Browser
Posts: 7
Registered: ‎08-02-2013

Re: g700s No Devices detected

sorry, i'm a little slow with technology so you'll have to explain what you mean by your above post.

 

is there a solution to getting LGS working for g700s ?

Logi Apprentice
Posts: 343
Registered: ‎07-09-2009

Re: g700s No Devices detected

Man if you will plug in a charging cable then you will see that G700s will have a Logitech driver!!!

Logi Browser
Posts: 7
Registered: ‎08-02-2013

Re: g700s No Devices detected

Negative.

 

When i plug in the cable, LGS still shows "No devices detected".

Logi Apprentice
Posts: 343
Registered: ‎07-09-2009

Re: g700s No Devices detected

Uninstall LGS

Clean PC with "CCLeaner"

Reboot PC

Install LGS again

 

See if it will help

Logi Browser
Posts: 7
Registered: ‎08-02-2013

Re: g700s No Devices detected

Thanks for the sugestion DJCasper but unfortunately, that didnt work either.

 

Logitech, please help with a solution, i have tried installing set point 6.52.74 with driver 5.52.29 and set point or LGS does not detect the mouse.

 

I am honostly thinking about returning this mouse and going with a razor or corsair.