Reply
AB1
Logi Nu
AB1
Posts: 1
Registered: ‎11-28-2009

Fix USB Mouse for Vista and Windows 7 Freeze

Method 1

*For Microsoft Windows Vista (and windows 7)
Click Start, and type device manager in the Start Search box.
Click Device Manager in the Programs list.
If you are prompted for an administrator password or confirmation, type your password or click Continue.
In the Device Manager dialog box, expand Universal Serial Bus controllers.
Right-click USB Root Hub and then click Properties.
In the USB Root Hub Properties dialog box, click the Power Management tab.
Remove the check from the Allow the computer to turn off this device to save power check box
. Repeat steps 1 through 4 for each USB Root Hub listed in the Device Manager.


Under Power settings, check the 'USB settings' -> 'USB selective suspend settings' and make sure it is disabled.

Check Thumbnail, highlighted: Open Device manager, Double click on Universal Serial Bus controller at the bottom, Double Click USB Root Hub, Click Power Management on top right, Uncheck Allow Power...

Method 2

*You can disable the USB Selective Suspend feature as a workaround by editing the registry. The USB device may become unresponsive because of a race condition in the Selective Suspend feature. The Selective Suspend feature suspends the USB device to efficiently maintain battery power by enabling the computer to turn off the USB device. However, sometimes this feature may not correctly wake up the USB device. Therefore, the USB device is unresponsive when you try to use it.
You might want to disable this feature for server products where power management is not important or required.
*To disable the Selective Suspend feature, follow these steps:
Click Start and then click Run.
Note If you are running Windows Vista, click Start, and then use the Start Search box.
Type regedit, and then click OK. Registry Editor opens.
Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Service es\USB
If the DisableSelectiveSuspend registry entry is present, double-click it. If it is not present, create the entry. To create the entry, follow these steps:
On the Edit menu, point to New, and then click DWORD.
Type DisableSelectiveSuspend, and then press ENTER.
On the Edit menu, click Modify.
In the Value data field, type 1 to disable the Selective Suspend feature, and then click OK.

Thanks to bmerdinian who authored this fix

http://forums.crackberry.com/f3/windows-7-vista-usb-fix-bmerdinian-195757/