Reply
Logi Nu
reba7
Posts: 1
Registered: ‎10-08-2009

M205

Hi,

I am new to this site.

My problem is with the M205 USB wireless mouse.  My computer doesn't recognize the mouse.  The green light comes on when you put the battery in. I never see a laser on bottom of mouse.  The moue is on and I press the connect button and I get nothing.  I have 4 USB ports and it will not work in any of them.  This is the second one I have bought and both have not worked.

Logi Legend
rlowens
Posts: 6,594
Registered: ‎05-22-2006

Re: M205

Try running the Unifying software util to reconnect the receiver and mouse.

-Richard L. Owens, author of the uberOptions mod for SetPoint. Unlock the options of your SetPoint-controlled device! mirror
Logi Nu
rowilso
Posts: 1
Registered: ‎03-11-2010

Re: M205

I have an M205 mouse and it was working early today and now it has stopped very similar to how the first post is mentioning. due to my own personal carelessness. I cannot find my software that came with the mouse.. is there anything on this website that can get this mouse to work.

Logi Nu
gdog23
Posts: 1
Registered: ‎03-20-2010

Re: M205

Hay my logitech have the same theing go on rigth now i can

not get it to cannet to UBS

Logi Nu
byebye009
Posts: 1
Registered: ‎02-21-2010

Re: M205 left button sticking

when i click on a window to move it or to resize it, with one click and hold of the button the mouse will not drop the window without clicking the button again

Logi Nu
driike
Posts: 1
Registered: ‎05-04-2011

Re: M205

[ Edited ]

I actually have the same problem with my M205. It worked perfectly until a windows update, now it doesn't work at all, even went through the pain staking process of formatting and reinstalling the OS (win7), still doesn't work. the unifying program doesn't recognize it either.

Retired Logitech Employee / Moderator (Inactive)
kpeppard
Posts: 789
Registered: ‎09-02-2009

Re: M205

Hello All:

 

Thank you for expressing concerns with your M205. For the great majority of you you seem to not have any connectivity between your mouse and receiver.

 

As noticed, I have included 2 links in regards to setpoint. Please install the appropriate version of setpoint whether your computer has a 32 or 64 bit Operating System.

32 bit: ftp://ftp.logitech.com/pub/techsupport/mouse/setpoint620j.exe

64 bit: ftp://ftp.logitech.com/pub/techsupport/mouse/setpoint620_x64.exe

 

Afterward please go to:

Start->All Programs-> scroll to Logitech->Unifying->Logitech Unifying Software

 

Please follow the instructions with the receiver plugged in. You may have to run this program a couple times to get the desired affect

 

If running the unifying software does not work please put your computer into a cleanboot mode and try running the unifying software from there. (see below)

http://logitech-en-amr.custhelp.com/app/answers/detail/a_id/228/~/booting-clean-in-windows-7,-vista,...

 

Other troubleshooting steps you can try are:

 

-does this device work on another computer

-in Device Manager is the mouse even showing up(enumerating) under Mice and Other pointing Devices

 

As for byebye009, if you go to: Start->Control Panel->Mouse->under button in the third section , is ClickLock checked or unchecked. If so then uncheck. If not then:

-try running in a cleanboot mode(see above)

-does it work on another computer

 

Regards,

 

Kevin

 

 

 

Knowledgebase | Downloads + Get Parts | Contact Support | Manuals | Warranty | Rebate
If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.
Logi Nu
Mell
Posts: 1
Registered: ‎08-19-2011

Re: M205

[ Edited ]

Download M305 connection utility. I just tried to install this mouse with the same problems everyone mentioned.

 

I downloaded the utility and it worked immediately when I followed the prompts.