Reply
Logi Nu
wzychee
Posts: 1
Registered: ‎12-11-2010

M510 Problem

After having a M510 mouse for about a month, it became incredibly hard to move the pointer. Originally, it would move over any surface with no problem, but now it hardly works on anything. Everything else works fine, but that hardly matters when I can't move the pointer. It's not that batteries.

Logi Nu
rebels
Posts: 1
Registered: ‎12-17-2010

Re: M510 Problem

I had this same problem. I called customer support and they told me how to fix it. First, try cleaning the laser lens with a dry cotton swab. If this doesn't work try taking the batteries out, then hold down the left mouse button while clicking the right mouse button 5 times. This should reinitialize the mouse. It woked for me. Good Luck.

Logi Browser
kevindd992002
Posts: 18
Registered: ‎08-24-2010

Re: M510 Problem

I'm experiencing the same problem. The M305 can be used on almost all surfaces except glass but this M510 has a very low laser-detection sensitivity. What's wrong?

Logi Browser
kevindd992002
Posts: 18
Registered: ‎08-24-2010

Re: M510 Problem

anyone please reply?!

Logi Browser
kevindd992002
Posts: 18
Registered: ‎08-24-2010

Re: M510 Problem

What a useless thread!!!!

Logi Browser
kevindd992002
Posts: 18
Registered: ‎08-24-2010

Re: M510 Problem

hello?!

 

reply!

Logi Nu
Logi-user
Posts: 1
Registered: ‎04-18-2011

Re: M510 Problem

I had this same problem except the mouse was brand new out of the box. No matter what surface I tried it on it would not track at all, it just jumped around with no control. I took the batteries out, then held down the left mouse button while clicking the right mouse button 5 times. Since then it's worked great, thanks for the tip!    

 

Logi Nu
Mozzarella
Posts: 2
Registered: ‎05-07-2011

Re: M510 Problem

I cleaned the laser with a dry cotton swab, changed the batteries, then took the batteries out and held the left button down while clicking the right one 5 times. I even bought a new mousepad, didn't change a thing. I'm having the exact same problem, but none of these have fixed it. Any ideas?

Retired Logitech Employee / Moderator (Inactive)
Cintech
Posts: 3,154
Registered: ‎04-01-2011

Re: M510 Problem

Hello Mozzarella,

 

 Sorry that your are experiencing issues with your M510 . You did exactly as customer care would have instructed . Have you moved the USB receiver to a different port ?  Also if you are using an external USB hub or pass through device , please disable it for trouble shooting purposes.  Try using the mouse on a plain white sheet of paper .  If none of these resolve the issue please contact customer care for your region.

 

Regards, 

Knowledgebase | Downloads + Get Parts | Contact Support | Manuals | Warranty | Rebate
If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.
Logi Nu
marinegundoctor
Posts: 2
Registered: ‎10-02-2011

Re: M510 Problem

I would say that kevindd992002 is more useless than this thread. rebels tip from Customer Service posted on 12-17-2010 did the trick for me. Maybe kevindd992002 should try reading the responses first!