Reply
Logi Nu
Seatown1two
Posts: 1
Registered: ‎03-31-2013

Marathon mouse M705 and application switching button

I believe my mouse might be defective.  My application switching button by the thumb area does absolutely nothing.  I've tried setting it to use alt+tab keystroke and application switcher option.   I have installed the latest version of setpoint and I am using windows 7 home premium 64bit.  Any suggestions?

Retired Logitech Employee / Moderator (Inactive)
Pau2108
Posts: 3,808
Registered: ‎08-02-2012

Re: Marathon mouse M705 and application switching button

Hello Seatown1two,

 

If you have already tried different button assignments on the Application Switcher button of your Marathon Mouse M705, and none of them worked. There's a chance that the issue might be related to the hardware, please try to use your M705 on a different computer. If the issue occurs there, please give a call to our support team. They will help you identify if the issue is related to the hardware and they can check if your M705 is under warranty.


I hope this helps Seatown1two, and that everything works out well.

Paulina
Support Specialist

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.

Logitech

Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.