Reply
Logi Nu
JamesBzx8
Posts: 2
Registered: ‎03-11-2010

SetPoint 4.80 or 6.0 installation fails

[ Edited ]
I am longing for the good old days when MouseWare ruled. Never a glitch with its installation. In February 2010 I wasted many hours trying to get SetPoint 4.x to install on my WinXP SP3 32bit. I had just bought an MX620. The installation always froze at step 4 of 5. Also, using windows TaskManager I could see that services.exe process was using 25% CPU. I once let it at that for a whole night and the next morning it was still stuck there. I could see in TaskManager process tab that a few of Logitechs installation modules were running, like setup.exe, setpoint and LDPinst.exe. It always appeared to be stuck because of a failure to install the driver package CDDRV. I have tried to install with Kaspersky Internet Security active and inactive, the SetPoint installation always fails. I tried with the MSconfig tool and disabling all unnecessary programs but the SetPoint installation still fails. I just bought another Logitech mouse: Performance Mouse MX and this came with the SetPoint 4.80H installation CD. So I said oh boy! Here we go again: Tried to install and it froze the same as it did in February 2010. This time I checked for any installation log files and found many pertaining to the SetPoint installation process: cddrvinstall.log , LDPINST.LOG, LkmdfCoInst.log, SetPoint_000.log, SetPoint_001.log, SetPointSummary_000.log, SetPointSummary_001.log, LuUpdater.log. How I wish Logitech Software team would work with users and these log files to quickly resolve any installation issues. I came back here at Logitech support website and checked if any progress or new reports about installation failures had been done. I then see that there is a new SetPoint version 6.00 released. I download this and try to install it. Again this fails and there is this new log file : sp6_setup.log. I see where the installation package puts its temporary files and decide to copy them closer to the root of the harddisk, precisely in C:\Temp\ instead of C:\DOCUME~1\JAMESB~1\LOCALS~1\Temp\ Without any logic, I remember somone posting he had an error with Microsoft Visual C++ component and I notice that in the Logitech SetPoint installation package there is a folder wich contains "Microsoft Visual C++ 2008 Redistributable Setup". I decide to run this and select the Repair option as I remembered that I already had some of the libraries from another program installation on my computer. After the repair is done, it asks to reboot the PC wich I did. I then proceeded to try again the installation of SetPoint 6.00 without turning off my Kaspersky Internet Security or disabling anything with MSconfig: SetPoint installed successfully for the first time in my life ! I repeat, SetPoint installed successfully for the first time in my life ! I believe it must have been the "Microsoft Visual C++ 2008 Redistributable Setup" repair operation I did that enabled SetPoint to install with success. I have all the tabs in the Logitech Control Panel and it sees both my mices: My MX620 and my Performance Mouse MX. Logitech needs in a hurry to get back to its software excellence they had in the '90s, in the days of MouseWare or risk migration out of their products as Symantec as experienced. I'm really hoping that my success leads many to their own installation successes ;-)
Logi Nu
mammon
Posts: 1
Registered: ‎11-07-2008

Re: SetPoint 4.80 or 6.0 installation fails

Thank you very much for the information.  However, I'm having trouble following you.  Could you more clearly specify the full path names to the files you mention (the log files, for instance).  Also, where in the SetPoint installation "package" did you find the stuff about the Microsoft Visual C++?  All I have when I download SetPoint 6.0 is a single file, setpoint600.exe; I see no "package".

Thanks again.  I'm very annoyed and discouraged at this point (I was a fool to take Logitech's bait to upgrade SetPoint; now I can't even get back to the old version that I had working); your post is perhaps my last straw.