Reply
Logi Nu
EKDS5k
Posts: 4
Registered: ‎03-27-2009

V450 Cordless Mouse won't turn on

I have this mouse for about a year, and it's worked mostly fine up until today.  This morning and afternoon it worked fine, and then I reinstalled my OS.  I used a different mouse to get the drivers and SetPoint all set up, but when I went to plug in the V450, it wouldn't turn on.  I've tried two sets of rechargeable batteries (one freshly charged) and one set of alkaline batteries fresh from the package.  I've tried putting the receiver into a different USB port.  Uninstalled and reinstalled the drivers and SetPoint.  No amount of rebooting or pressing the power button on the bottom of the mouse makes any difference.

 

Anybody have any ideas what's up?  I really hope I'm just missing something easy, and that I don't have to go through official support.  Especially since I can't find my warranty information.

 

Thanks in advance. 

Support Specialist
CJChew
Posts: 6,545
Registered: ‎06-21-2007

Re: V450 Cordless Mouse won't turn on

Hi:smileyhappy:,

 

Is your system able to at least detect the receiver? Also, please check if tehre are any errors in Device Manager.

Logi Nu
EKDS5k
Posts: 4
Registered: ‎03-27-2009

Re: V450 Cordless Mouse won't turn on

[ Edited ]

Hello CJChew,

 

Yes, the system finds the receiver properly, and comes up in Devicec Manager as "Logitech HID-compliant Cordless Mouse."  There are no errors, and like I said I have tried uninstalling and reinstalling the drivers twice now.  Even odder is that when I hover the cursor over the setpoint icon in the system tray with the receiver plugged in, it says the batteries are good, even though the actual mouse isn't turned on and has no batteries in it.

 

Thanks for your reply. 

Message Edited by EKDS5k on 06-07-2009 10:52 PM
Logi Nu
EKDS5k
Posts: 4
Registered: ‎03-27-2009

Re: V450 Cordless Mouse won't turn on

I hate to bump threads, but nobody has any ideas?