Reply
Logi Nu
tiffsedge
Posts: 1
Registered: ‎10-07-2011

m305 won't left click and drag

I have tried to download set point but I am getting an error on the page. I do not know what happened but I suddenly cannot left click and drag . Like if I am on my desktop and want to move a picture to a file I can click on the picture but it won't drag at all. I have checked all my settings and I have no idea what happened or what to do. I am running windows 7 64 bit.

Retired Logitech Employee / Moderator (Inactive)
ebona
Posts: 451
Registered: ‎02-07-2011

Re: m305 won't left click and drag

Hi tiffsedge,

 

Please try taking the batteries out of the mouse and holding down the left and right click for 15 seconds, then putting the batteries back into the mouse. If that doesn't help, try the wireless receiver in a different usb port. 

 

Does the mouse also double click sometimes when you try to click on things?

 

Regards,

Knowledgebase | Downloads + Get Parts | Contact Support | Manuals | Warranty | Rebate
If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.
Logi Nu
DazeDreamr
Posts: 1
Registered: ‎02-18-2012

Re: m305 won't left click and drag

My M305 started acting up a two days ago. It won't right click and drag now and it double clicks randomly when I want it to single click. I tried removing battery and holding down left and right button 15 second idea but it didn't help. I have no idea how to remove the 'dongle' driver in order to re-install it or if it would help fix the problem. I checked my mouse settings,  I use Win 7 Pro everything looks the same, no changes. 

 

If it helps, I can left click and drag but it does Click Lock and I would rather just hold the right button down to click and drag.

Logi Nu
ivankennethwang
Posts: 1
Registered: ‎10-20-2013

Re: m305 won't left click and drag

Is there any other solutions for this? I'm also experiencing this recently for the past week with Mac OS X 10.8, Mac OS X 10.9 and Windows 8. Seems like any computer/mac used. There were no problems before, and I did not change anything.

 

Thanks!