Reply
Logi Nu
saxmankk
Posts: 1
Registered: ‎11-10-2012

m705 scroll wheel works, just won't scroll

I've run into a strange problem with my M705 mouse: The scroll wheel will no longer scroll.  I didn't change anything in the settings...it just stopped scrolling.  That doesn't mean the wheel is broken...when I switch the middle button function to zoom, the scroll wheel zooms in and out as appropriate.  I just can't get it to scroll.  I've checked in the mouse setting in the Control Panel (I'm on win 7, btw), and all through the SetPoint software, but can't figure it out.  In fact, I used the Restore Defaults option in the SetPoint software, and it still didn't fix the problem.  So, to recap: hardware is fine, because it works for zooming, just won't scroll; plugged the cheapo mouse that came with my PC in, and the scrolling worked fine, so its not as if scrolling is switched off somewhere in win 7.  This is a new PC, and I just downloaded and installed the newest drivers and software, so I can't rollback drivers or anything.  I'll also point out: it worked fine for several days, then just stopped.

 

Any help appreciated

Support Specialist ★★★★
daleLogi
Posts: 5,919
Registered: ‎01-06-2010

Re: m705 scroll wheel works, just won't scroll

Hello saxmankk,

 

To help resolve the issue, try the following troubleshooting steps:

 

-Test the scroll wheel in different applications.

-Test the scroll wheel in hyper scroll or click to click mode (Press the scroll mode button on top of the mouse to change scrolling mode).

-Uninstall the Logitech Setpoint Software and check if the scroll wheel works without it.

-Test your Logitech Marathon Mouse M705 on another computer.

 

daleLogi

Support Specialist

 

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.

      
Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.

 

 

Logi Nu
pkincy
Posts: 2
Registered: ‎01-08-2013

Re: m705 scroll wheel works, just won't scroll

Had the same problem with the same mouse on my desktop.

 

A simply change of the unifing sender from one USB port to another solved the problem for me.  Odd, but that is all it took and all other functions other than scorll worked in the old USB port.

 

Go figure.

Logi Nu
kaiser3731
Posts: 1
Registered: ‎02-26-2013

Re: m705 scroll wheel works, just won't scroll

[ Edited ]

Your since your reply is newer I chose to reply to you. I just got this device and this literally just happened to me. I use Google Chrome as my browser and it is truly annoying for it to change my zoom level. However I seemed to have fixed mine. You may have some kind of lock on your keyboard, be it scroll lock, cap lock, etc. Somehow my Logitech K350 keyboard locked my CTRL key down, not like the key mechanically got stuck down, but electronically got stuck down. All I did was press my CTRL key and bam, my pages no longer zoom in/out and the scroll wheel seems to be working correctly again. Signals may get crossed between the unifier and the devices sometimes. Since "unifying" is relatively new from Logitech, there are bound to be some small bugs, and this may be one of them. Nice fix BTW, I guess my old Mortal Kombat days still have me button mashing for the right combo to fix things.

Logi Browser
Vorz
Posts: 12
Registered: ‎09-10-2007

Re: m705 scroll wheel works, just won't scroll

This issue just happened to me today. It happens in all applications on my windows 8 pc, tried different ports and still no scrolling. Also tried on my mac mini and it wasn't working on there either. Annoying because this mouse was perfect for me until this happened. 

Logi Nu
atulksh
Posts: 1
Registered: ‎06-29-2013

Re: m705 scroll wheel works, just won't scroll

It happened to me today as well. The scroll just stopped working in ALL browsers or any other apps. I first tried to switch the usb port but that did not help although it reinstalled the device driver.

 

Finally I located the Set Point software from the Control Panel/Programs and Features and un-installed it. During un-installation I could see that the device driver was "re-installed" as it was uninstalling. Do not know what that means.

 

But after the program was uninstalled the scroll worked like a charm. I don't care about the set point software. If you do maybe you could try to re-install it again once your scroll starts working hoping that it would not break it again!

 

Hope this helps.

Logi Nu
Lefty7
Posts: 1
Registered: ‎07-30-2013

Re: m705 scroll wheel works, just won't scroll

I had the same issue with both an M705 and M510 using unify receiver on windows 7 64bit.

 

Problem started after a logitech system tray icon appeared and looked like it was installing an update of some kind.  

 

This is a bug in setpoint update and Logitech needs to fix. I hope they are aware of the issue.

 

Uninstall Setpoint. It will reinstall regular device drivers during the process and then it will work fine. Setpoint is useless anyway.

Logi Nu
Radwarrior
Posts: 3
Registered: ‎02-20-2012

Re: m705 scroll wheel works, just won't scroll

[ Edited ]

My scroll wheel would work for a few seconds while the system was loading, then quit. If I switched the dongle to another USB port, it would work for a few seconds then quit. This suggests a bug in the Logitech driver, and I agree that it must have come from an update that I didn't approve.

 

I uninstalled the Setpoint software and the wheel sprung back to life. Of course, the rest of the cool functionality didn't work. Then I installed the newer version of the SetPoint software and everything works again.