Reply
Logi Nu
xixueguiBZ
Posts: 1
Registered: ‎02-06-2009

Logitech USB Headset Microphone Problems: No sound recording?

[ Edited ]

Windows XP Media Center Edition

I recently installed and set up the Logitech USB headset, but I cannot record sound.  The device manager shows the device working properly, and in audio properties/sound recorder I have logitech usb headset set to the default.  I hear sound, but when I speak, it doesn't record (tried with Windows Sounder Recorder, Skype, Praat, Ventrilo, QQ, etc).  When I open the volume window, if I mute the sound, the red light indicating it is muted comes on on the headset, but when I unmute it, I still cannot record.  The default microphone works fine, but whenever I switch to the USB, it simply does not register any sound.  I've gone through all the audio properties, maxed out the volume for microphone (playback and recording), unmuted everything, the default device shows up correctly... but still no sound.  I would assume the microphone was not connected somehow (a wire came loose inside?)  except the red light comes on when I mute it.  What else can I do?

Message Edited by xixueguiBZ on 02-06-2009 04:31 AM