Reply
Logi Nu
megaflop
Posts: 2
Registered: ‎12-27-2011

WMA lossless playback problem on Sony BDP-S480 (Logitech Media Server 7.7.1)

Hello,

 

I apologize if this is the wrong forum.

 

I am having trouble getting my Sony BD player to work with my WMA lossless files. It connects to the Logitech Media Server and can see all the media files (the are identified as type LPCM) when I attempt to playback a file I get a "corrupted file or invalid format" error on the BD player.

 

These same files playback correctly through Asset UPnP server which is also transcoding them to LPCM. I would rather just have one source for all my music and would prefer to use the Logitech Media Server.

 

Thank you for any help,

-MegaFlop

 

 

Logi Guru II
squeezeit
Posts: 3,271
Registered: ‎09-30-2010

Re: WMA lossless playback problem on Sony BDP-S480 (Logitech Media Server 7.7.1)

[ Edited ]

I don't know if LMS transcodes for non-SqueezeBox players (i.e. DLNA devices).  I believe the DLNA device must be able to play the file natively to use LMS.  I know this is true for video files.

 

However you could try to set LMS to transcode WMA Lossless to a format your Sony will play, worth a shot.

LMS > Settings > Advanced > File Types > WMA Lossless > *disable* all

 

I think LMS default is to transcode WMA Lossless to FLAC, maybe disabling this will send the WMA Lossless to the Sony, assuming Sony can play that.

 

Logi Nu
megaflop
Posts: 2
Registered: ‎12-27-2011

Re: WMA lossless playback problem on Sony BDP-S480 (Logitech Media Server 7.7.1)

thanks squeezeit,

 

I think I might just be out of luck. I tried messing around with the "File Types" settings although I didn't try disable all since I have a SqueezeBox Duet in a different room that plays the WMA Lossless with no problems.

 

I did disable the transcode WMA Lossless to FLAC and that didn't seem to help. Do you need to restart the server for the transcode changes to take effect?

 

So the big question is if LMS can transcode for DLNA devices (Sony BD)?

 

thanks,

-MegaFlop

Logi Guru II
squeezeit
Posts: 3,271
Registered: ‎09-30-2010

Re: WMA lossless playback problem on Sony BDP-S480 (Logitech Media Server 7.7.1)

I think if you disable all but WMA Lossless (leave as native) then you are disabling transcoding.  But then you run into many unknowns:

 

-  will the Sony play that format?

-  will you now not have access to that file on your Duet?

-  does LMS transcode at all for DLNA devices?

 

A lot of unknowns.  :smileysad:

 

Maybe ask in the Revue section of these forums.