Reply
Logi Nu
walkerbk
Posts: 4
Registered: ‎12-30-2010

HBOGO won't load

HBOGO will not load a video. I can sign in using my Uverse username and password but when I choose a video, it never loads completely ending up with an error prompt. I get the same result using a wireless connection or a wired connection to my network. The other video applications in Spotlight seem to work properly. I can view HBOGO from other computers on my home network but not on the Revue. Can anyone help?

Logi Apprentice
steveko
Posts: 143
Registered: ‎01-04-2010

Re: HBOGO won't load

Is it forcing you to login through your HBO provider (Uverse)? That might be the problem right there. When I try to logon to HBOGO it forces me to login to it via Comcast (my HBO cable provider).

Logi Nu
walkerbk
Posts: 4
Registered: ‎12-30-2010

Re: HBOGO won't load

You can't watch HBOGO unless you have a subscription through an HBO provider. You have to log in to use it. I don't think that is the issue.

Logi Apprentice
steveko
Posts: 143
Registered: ‎01-04-2010

Re: HBOGO won't load

[ Edited ]

That's exactly the problem if you're a Comcast Cable HBO subscriber because they force you to access HBOGO through Xfinity TV which isn't supported by Google Chrome. And this stinks - I had thought Google had a partnership with HBO to offer HBOGO access via Google TV regardless of who the provider of service was (e.g. Comcast, Uverse, etc)???

Logi Nu
walkerbk
Posts: 4
Registered: ‎12-30-2010

Re: HBOGO won't load

Its working fine today. I think its a server issue.

Logi Apprentice
steveko
Posts: 143
Registered: ‎01-04-2010

Re: HBOGO won't load

Glad it working for you. But that won't help my issue because with Comcast you have to access HBOGO via the Xfinity.TV Fancast website http://www.fancast.com/, and HBOGO is NOT supported on Google TV Android OS/Chrome for that! :smileysad: