Reply
Logi Nu
FloOFy2
Posts: 3
Registered: ‎02-03-2011

Annoying static on S-120

[ Edited ]

Hey, I just got these new Logitech S-120 and it's having this really annoying static noise. It's not that loud if there's sound playing but it gets annoying when it's just sitting idle. I've checked and it has nothing to do with the computer,  even if I unplug the speakers from my computer the static still persists, the static is apparent if the speakers are just plugged in and turned on. The static only comes from the left speaker (the secondary one without the headphone jack nor volume control).

 

The wires are just passing by other wires, a power brick from my screen and into my computer 3.5mm jack. Other than that there's an LCD screen and a wireless card (in my computer) by it. I doubt the static can be coming my my wireless card because the speaker that's working is closest to it and it has absolutely no static.

 

Is this a defect or a way to fix this? Note that there are no cell phones by either.

 

*EDIT: Changing the volume on the speakers or through the computer does not change the volume of the static, it only stops when the speakers are turned off and starts again when it's turned on*

Logi Nu
FloOFy2
Posts: 3
Registered: ‎02-03-2011

Re: Annoying static on S-120

*bump*

cna
Logi Nu
cna
Posts: 1
Registered: ‎08-16-2012

Re: Annoying static on S-120

Similar  problem, have you had any luck?

Both speakers actually make horrible noise, any suggestion?

Nothing wireless in vicinity.

Thx!