Reply
Logi Nu
n8mill
Posts: 1
Registered: ‎01-08-2009

Logitech Z560 Speaker System Problem

First of all I appologize if this post should be on another board.  I saw no board for 4.1 speaker systems.  

 

I have had the Logitech Z560 Speaker System for a few years.  Shortly after plugging them in, one or multiple speakers would start to fuz (make static noise) instead of playing the music I had on.  I would tap the receiver (volume control) and it would fix itself.  Slowly this problem would occur more often to the point the speaker(s) would fuz and the base would make a loud noise until I tapped the receiver or giggled the wires on the back of the receiver.  This problem has made it to the point that I almost avoid using my speaker system.  

 

I realize it's many years after purchase and there is most likely no warrenty on a product as such, however I was interested in purchasing a replacement receiver of some sort.  I have tested the speakers on other devices and they all work properly.  I feel as though the problem could be fixed with a new receiver.  Is there any way I could purchase and old refurb or is there even a spare part I could purchase that would work with my system.  As I said, I'd like to fix this problem without having to purchase new speakers and another sub.  

 

Any help or assistance would be appreciated.  Thanks.

 

-n8

Logi Master
REDNOSEPITBULL
Posts: 715
Registered: ‎09-12-2007

Re: Logitech Z560 Speaker System Problem

Try calling Logitech but i doubt they will have any parts for it. Try ebay you might find it there.
Logi Nu
realmuffin
Posts: 2
Registered: ‎07-27-2009

Re: Logitech Z560 Speaker System Problem

Hey, same problem here. I called Logitech support and they said to try the forums.. I'm looking for the same replacement part.
Logi Nu
WHATYOUSAY
Posts: 1
Registered: ‎05-31-2010

Re: Logitech Z560 Speaker System Problem

Mine had the same problem and I opened the volume control and sprayed it with air to clean out the magnetic dust that accumulated in side it. I had to do this two or three times. First spray it and turn your volume knob (this will lubricate it) then spray it again. Use it for a day or so and if need to do it again. The static will dissipate but not completely until you do this process the second or third time, but you have to give it some time for the volume control to work this stuff free. Now I do not have to buy new speakers.

Logi Journeyman
Hammey
Posts: 368
Registered: ‎05-22-2009

Re: Logitech Z560 Speaker System Problem

Hi it is always best to say where your from when you are asking for parts most of us that have parts laying around dont really want any money for it, but dont really want to pay to post it from lets say canada to china. So in this case although I have a good one laying around here for years and it worked when i put it away im not going to ship it to the other side of the world lol.

Logi Nu
p3sponge
Posts: 1
Registered: ‎03-21-2011

Re: Logitech Z560 Speaker System Problem

Do you still have the control unit from you z560?  I know its been a while.

If so...would you be interested in selling it?

I would be willing to part with $50 or even $60 for it.

Logi Nu
SetantaKing
Posts: 1
Registered: ‎05-12-2011

Re: Logitech Z560 Speaker System Problem

I have a 'broken' subwoofer, but have the 'upright' controller unit, I am trying to get an online fix for my problem, if I cannot find one I would be willing to sell you the unit...I live in Ireland ok...give me a few days and will contact you through this forum...and let you know either way...Please confirm...Slan

Logi Nu
DiRtDoG62
Posts: 1
Registered: ‎05-27-2011

Re: Logitech Z560 Speaker System Problem

[ Edited ]

I have the controller as  I think my amp in the subwoofer is fried as I can't get anything to play out of my speakers :smileysad:  dar n so much for listening to music at work (wonder if I should bring in my Z-5500 instead) :smileyvery-happy:

Logi Nu
xuboi
Posts: 1
Registered: ‎05-27-2011

Re: Logitech Z560 Speaker System Problem

Hey guys I'm new to the forum but I did notice that there were some recent posts on this older thread and I was wondering if anyone had a spare speaker (working) that is compatible with the z-5300 set? I know the z-2300 also used the same drivers and the z-560 look very similar. I think I would have to solder the wires but I would be willing to buy one if its reasonably priced. I live in Canada by the way. Thanks in advance :smileyhappy:

Logi Nu
Nobodyhearsyou
Posts: 2
Registered: ‎06-07-2011

Re: Logitech Z560 Speaker System Problem

@ SetantaKing:

 

 I'd be interested in the control unit. Let me know if you are going to sell or not.