Reply
Logi Nu
pmycrth
Posts: 1
Registered: ‎01-21-2009

X-530 Speakers, only front two working. PLEASE SOMEONE HELP :(

[ Edited ]

Basically ive just bought the X-530 Logitech speakers for my Dell Dimension PC (Its a few years old, but still runs everything fine).

 

I've read lots of posts about sound cards being 5.1 compatible. I'm not exactly sure if mine are, they have got all the required ports to plug in the cables for the speakers, but I can still only get sound from the front left and front right speakers. Ive been on control panel to the sound section and changed the settings to 5.1 speakers, but still nothing.

 

Any help on what could be the problem would be much appreciated. My guess is that my sound card isnt compatible and i'll have to get a new one... im just hoping i'm wrong.

 

Thanks x

 

....by the way, I think its the front central speaker, appears to make popping sounds every now and again... even though I get no other sound from it.

Message Edited by pmycrth on 01-21-2009 08:54 AM
Message Edited by pmycrth on 01-21-2009 09:21 AM
Logi Master
Astrallite
Posts: 718
Registered: ‎01-23-2007

Re: X-530 Speakers, only front two working. PLEASE SOMEONE HELP :(

Are you talking about movies or games?

 

For movies, what video program are you using?

______________________________________________
avsforum.com - what can your HT do for you today?
Logi Guru
Patboy
Posts: 2,801
Registered: ‎11-09-2006

Re: X-530 Speakers, only front two working. PLEASE SOMEONE HELP :(

Hi, the content you are playing also needs to be in 5.1. Music is not 5.1.
PC Specs: C2Q Q6600 @2.4Ghz, 3gb DDR2 memory, ATI Radeon HD2600PRO, Windows Vista Home Premium 32-bit, Logitech Z-5500, Logitech Z-5300e, Logitech Z-2300e Logitech EX110, Logitech Quick Cam Chat, Logitech diNovo for keyboard, Logitech VX Revolution, Samsung SyncMaster 203B, LG 206WTQ