Reply
Logi Browser
TacoKing
Posts: 6
Registered: ‎07-06-2012

Squeezebox Radio keeps dropping wifi connection

I've had Squeezeboxes for a while, and never had a wifi problem until now. The player loses the wifi connection several times a day, and then claims my wifi is offline. It displays the red signal meter, and if I check "Signal Strength" it says there is no signal for that network.

 

This is just incorrect. I am very technicaly, and have troubleshot everything else I can think of. My ssid isn't broadcast, but it connects just fine when it first powers up. If I off/on the squeezebox it sees the network fine, then loses it after a while. I've moved the box within 10 feet of my router to rule out signal strength, and when the box does see the network it reports 100% strength. I'm using a WPA2-PSK, but can't see how the security could be the issue. Same for some sort of DHCP address problem, because it's not reporting that it can't get an IP... it says it can't see the network at all. And I just ran the software update again to make sure I'm current - didn't help.

 

I've looked through the forum and support docs but haven't seen anyone reporting this. Did I just get a dud radio? Ideas?

 

Thanks!

Logi Guru
garymc
Posts: 1,802
Registered: ‎06-23-2010

Re: Squeezebox Radio keeps dropping wifi connection

any new neighbors with wifi.  Use something like inSSIDer to see what the nearby WIFI channels are and use something not in use nearby (preferably 1, 6, or 11, as these don't overlap with nearby channels).  Do not use > 11 and don't use any "auto" feature of a router to find empty channel (which could be different each time used). 

_____________________
***I don't work for Logitech...I'm just another user***
Location 1: Vortexbox Appliance 4TB (2.3) > LMS 7.8 > Transporter, Touch, Boom, Radio w/Battery (all ethernet except Radio)
Location 2: VBA 3TB (2.3) > LMS 7.8 > Touch > Benchmark DAC I, Boom, Radio w/Battery (all ethernet except Radio)
Office: Win7(64) > LMS 7.8 > SqueezePlay
Spares: VBA 4TB, SB3, Touch (3), Radio (3), CONTROLLER
Controllers: iPhone (iPeng), iPad (iPengHD & SqueezePad), CONTROLLER, or SqueezePlay 7.8 on Win7(64) laptop
Files: Ripping (FLAC) - dbpoweramp, Tagging - mp3tag, Spotify
Logi Browser
TacoKing
Posts: 6
Registered: ‎07-06-2012

Re: Squeezebox Radio keeps dropping wifi connection

Thanks for the reply! I don't think there is any new wifi interference, but I will look. I scanned for this when I set up the router, and nobody new has moved in nearby. Plus, no hardware of mine is having problems, even at much greater distances. But it's a valid thing to rule out, so I'll run a scan.

 

Any other suggestions? I'll rule it out but really can't see interference being the culprit here.

Logi Guru
garymc
Posts: 1,802
Registered: ‎06-23-2010

Re: Squeezebox Radio keeps dropping wifi connection

Hmmm, I might do a factory reset.  And it is not required, but I find my SB players all work better with fixed IP addresses (not just reserved in router). You can do this in RADIO by termporarily turning OFF DHCP in your router. Then do a factory reset on Radio and when it fails to get an IP address it will offer up a menu to do it manually.  For me, my DHCP starts at .100, so I use:

 

router is 192.168.1.1

 

 

IP:  192.168.001.020

Subnet: 255.255.255.000

gateway:  192.168.001.001

DNS: 192.168.001.001

_____________________
***I don't work for Logitech...I'm just another user***
Location 1: Vortexbox Appliance 4TB (2.3) > LMS 7.8 > Transporter, Touch, Boom, Radio w/Battery (all ethernet except Radio)
Location 2: VBA 3TB (2.3) > LMS 7.8 > Touch > Benchmark DAC I, Boom, Radio w/Battery (all ethernet except Radio)
Office: Win7(64) > LMS 7.8 > SqueezePlay
Spares: VBA 4TB, SB3, Touch (3), Radio (3), CONTROLLER
Controllers: iPhone (iPeng), iPad (iPengHD & SqueezePad), CONTROLLER, or SqueezePlay 7.8 on Win7(64) laptop
Files: Ripping (FLAC) - dbpoweramp, Tagging - mp3tag, Spotify
Logi Browser
TacoKing
Posts: 6
Registered: ‎07-06-2012

Re: Squeezebox Radio keeps dropping wifi connection

Just following up, but so far no success.

 

I scanned for conflicting wifi signals, and everyone nearby is at 1 or 6. I took my router out of auto-channel and set it to 11. Neither of these helped with the problem. The wifi reports at 100% signal strength until is just suddenly disappears.

 

The only thing left would be a fixed IP, but I really don't want to set that up on my wifi just for this box. My old Squeezebox Boom works like a champ on my same network even further away from the router. It really looks to me like A) Logitech has some bad hw/sw in their wifi radio setup, or B) I got a bad device. 

 

Unless anyone has another idea, I'm probably going to return it as defective. :smileysad:

Logi Guru
garymc
Posts: 1,802
Registered: ‎06-23-2010

Re: Squeezebox Radio keeps dropping wifi connection

perhaps you have a bad device. if under warranty, just return for replacment. I have two RADIOS with no issues at all on two different location's networks. Adn they've had several firmwares since I've owned them, including the most recent. Always worked well for me.

 

p.s. setting a fixed IP has nothing to do with your router. You set it in the RADIO network setup. Only connection to router is that you give it a fixed IP address (in the RADIO) outside the range that your router hands out to things on the network. 

 

Not required, but all devices I own that never leave the house have a fixed IP address (not simply "reserved" on router), and that includes all my SB players.

_____________________
***I don't work for Logitech...I'm just another user***
Location 1: Vortexbox Appliance 4TB (2.3) > LMS 7.8 > Transporter, Touch, Boom, Radio w/Battery (all ethernet except Radio)
Location 2: VBA 3TB (2.3) > LMS 7.8 > Touch > Benchmark DAC I, Boom, Radio w/Battery (all ethernet except Radio)
Office: Win7(64) > LMS 7.8 > SqueezePlay
Spares: VBA 4TB, SB3, Touch (3), Radio (3), CONTROLLER
Controllers: iPhone (iPeng), iPad (iPengHD & SqueezePad), CONTROLLER, or SqueezePlay 7.8 on Win7(64) laptop
Files: Ripping (FLAC) - dbpoweramp, Tagging - mp3tag, Spotify
Logi Browser
TacoKing
Posts: 6
Registered: ‎07-06-2012

Re: Squeezebox Radio keeps dropping wifi connection

I know - I just have my LAN set up to only allow dedicated IPs for a few systems, and everything else is in a tight DHCP pool. It would reject anyone claiming a set IP without some reconfig. But I really think the thing is just defective at this point. I did want to thank you for your time in helping me troubleshoot it. You were the only one who replied, and I appreciate it!
Logi Guru
garymc
Posts: 1,802
Registered: ‎06-23-2010

Re: Squeezebox Radio keeps dropping wifi connection

I hope the replacement turns out to work.  I use my SB devices probably 8 hours a day and they are very nice....

_____________________
***I don't work for Logitech...I'm just another user***
Location 1: Vortexbox Appliance 4TB (2.3) > LMS 7.8 > Transporter, Touch, Boom, Radio w/Battery (all ethernet except Radio)
Location 2: VBA 3TB (2.3) > LMS 7.8 > Touch > Benchmark DAC I, Boom, Radio w/Battery (all ethernet except Radio)
Office: Win7(64) > LMS 7.8 > SqueezePlay
Spares: VBA 4TB, SB3, Touch (3), Radio (3), CONTROLLER
Controllers: iPhone (iPeng), iPad (iPengHD & SqueezePad), CONTROLLER, or SqueezePlay 7.8 on Win7(64) laptop
Files: Ripping (FLAC) - dbpoweramp, Tagging - mp3tag, Spotify
Logi Browser
DebbieKat
Posts: 18
Registered: ‎09-18-2011

Re: Squeezebox Radio keeps dropping wifi connection

I'm experiencing the exact same issue. I've had the squeezebox for about 6 months. My wifi is fine as all of my other devices are connecting without any issues. I notice that when it loses the connection and asks me to try to connect again, if I choose try another network, my wifi is on the list and has a full signal. Sometimes when I select it from here it connects again right away. Other times I try several times before I can get it to connect again. I also updated my software to see if that would resolve the issue and it hasn't. I have also restarted my modem and router to no avail.

Logi Browser
DebbieKat
Posts: 18
Registered: ‎09-18-2011

Re: Squeezebox Radio keeps dropping wifi connection

By the way, my issue only began probably in the last 3 weeks. I wonder if Logitech has changed something in the firmware? It never had this problem before.